settingsLogin | Registersettings

[openstack-announce] [new][ironic] python-ironicclient 1.8.0 release (ocata)

0 votes

We are pumped to announce the release of:

python-ironicclient 1.8.0: OpenStack Bare Metal Provisioning API
Client Library

This release is part of the ocata release series.

The source is available from:

http://git.openstack.org/cgit/openstack/python-ironicclient

Download the package from:

https://pypi.python.org/pypi/python-ironicclient

Please report issues through launchpad:

http://bugs.launchpad.net/python-ironicclient

For more details, please see below.

1.8.0
^^^^^

Upgrade Notes


  • Hide nodes field in 'chasiss create' and 'chassis show' OSC
    subcommand output because this field is not meant for CLI users.

  • Hide ports field in 'node create' and 'node show' OSC subcommand
    output because this field is not meant for CLI users.

Bug Fixes


  • If a node does not have "chassis_uuid" field in the API response,
    it is added to the output of the node commands as an empty string.

  • Fixes an issue in a python 3 environment, where TypeError
    exceptions were being raised (due to the "requests" library
    returning bytes instead of a string).

  • Fixes 'ironic create ' command so that it handles the file
    argument(s) correctly.

  • For node resources that had no boot devices, no supported boot
    devices, or no passthru methods (and driver resources with no
    properties or no passthru methods), issuing a request to get that
    information (for example, 'ironic driver-get-vendor-passthru-methods
    fake') would result in the error "'NoneType' has no attribute
    'to_dict'". This is fixed; an empty list is now returned.

  • Fixes the OpenStackClient plugin so that it uses the same default
    API version as the Ironic CLI (1.9 instead of 1.6).

  • Fixes the OpenStackClient plugin so that microversions 1.21 and
    1.22 are supported.

Changes in python-ironicclient 1.7.0..1.8.0


e512550 Fix python3 compatibility when HTTP Error are returned
32c415e Updated from global requirements
316d69e Avoid string interpolation in logging calls
8c38559 Updated from global requirements
6c71d87 Use function importversionedmodule from oslo.utils
d16aab6 Updated from global requirements
921db52 Fixed json response func tests
d35a75c Fix display of chassis UUID field if empty
ad14c62 [trivial] Remove unused variables assignment
b1da714 Updated from global requirements
4bf0e02 Add plug-in summary for osc doc
bff2693 Updated from global requirements
b03a22d Set OSC default baremetal api version as in ironicclient
11eae85 Fix import of ironicclient and reformat docstring
126cdb9 Update .gitignore to ignore .idea of PyCharm
c3e28cd Enable release notes translation
8a8fdc4 Add docs for create command
cfe4021 Refactor provision state so all actions can use inherited takeaction
109b438 If no resource, don't call Resource.to
dict()
5b67658 Updated from global requirements
f11ad70 Add prefix "$" for command examples
2a36c06 TrivialFix Remove white space between print and ()
e7d8823 Use ConfigParser instead of SafeConfigParser in Python 3
9f135f3 Hide 'nodes' field from chassis OSC subcommands output
728063c Hide 'ports' field from node OSC subcommands output
96554a9 'ironic create' handles file args
910989a standardize release note page names and ordering
b8670a8 Document updating nested node attributes with CLI
8a9daaf OSC plugin support microversions 1.21 & 1.22
5bd2e8d Update reno for stable/newton
7e38347 Include jsonschema only once in requirements
a9fd604 use utils.keyvaluepairstodict()
2403219 Move duplicated info to new v1/utils.py
f72aa9e Don't write python bytecode while testing

Diffstat (except docs and test files)


.gitignore | 1 +
README.rst | 22 +--
ironicclient/client.py | 5 +-
ironicclient/common/base.py | 14 ++
ironicclient/common/cliutils.py | 2 +-
ironicclient/common/http.py | 25 ++-
ironicclient/common/utils.py | 8 -
ironicclient/osc/plugin.py | 13 +-
ironicclient/osc/v1/baremetalchassis.py | 6 +-
ironicclient/osc/v1/baremetal
driver.py | 14 +-
ironicclient/osc/v1/baremetalnode.py | 71 +++------
ironicclient/osc/v1/baremetal
port.py | 6 +-
ironicclient/shell.py | 7 +-
ironicclient/v1/createresourcesshell.py | 2 +-
ironicclient/v1/driver.py | 5 +-
ironicclient/v1/drivershell.py | 9 +-
ironicclient/v1/node.py | 11 +-
ironicclient/v1/node
shell.py | 53 ++-----
ironicclient/v1/port_shell.py | 2 +-
ironicclient/v1/shell.py | 5 +-
ironicclient/v1/utils.py | 48 ++++++
...assis-uuid-if-it-is-empty-a5471c3aa740a27d.yaml | 5 +
...fix-python3-compatibility-993ace45fefcba34.yaml | 5 +
.../ironic-create-files-fix-c31e40e566ff86b8.yaml | 4 +
...o-resource-attributeerror-d0cb327abab7dcc0.yaml | 8 +
.../osc-default-microver-172d6e69316e70c1.yaml | 4 +
.../osc-max-microver-22-dc0d91a62f03a2e6.yaml | 4 +
...n-chassis-create-show-fix-ee276d707c5a5bdf.yaml | 5 +
...ugin-node-create-show-fix-283148c86fbccce2.yaml | 5 +
releasenotes/source/conf.py | 3 +
releasenotes/source/current-series.rst | 5 -
releasenotes/source/index.rst | 3 +-
releasenotes/source/newton.rst | 6 +
releasenotes/source/unreleased.rst | 5 +
requirements.txt | 13 +-
test-requirements.txt | 13 +-
tox.ini | 1 +
53 files changed, 620 insertions(+), 328 deletions(-)

Requirements updates


diff --git a/requirements.txt b/requirements.txt
index 004b3d2..24b7cc7 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -8,2 +8,2 @@ jsonschema!=2.5.0,<3.0.0,>=2.0.0 # MIT
-keystoneauth1>=2.10.0 # Apache-2.0
-osc-lib>=1.0.2 # Apache-2.0
+keystoneauth1>=2.14.0 # Apache-2.0
+osc-lib>=1.2.0 # Apache-2.0
@@ -11,4 +11,5 @@ oslo.i18n>=2.1.0 # Apache-2.0
-oslo.utils>=3.16.0 # Apache-2.0
-PrettyTable<0.8,>=0.7 # BSD
-python-openstackclient>=2.1.0 # Apache-2.0
-PyYAML>=3.1.0 # MIT
+oslo.serialization>=1.10.0 # Apache-2.0
+oslo.utils>=3.18.0 # Apache-2.0
+PrettyTable<0.8,>=0.7.1 # BSD
+python-openstackclient>=3.3.0 # Apache-2.0
+PyYAML>=3.10.0 # MIT
diff --git a/test-requirements.txt b/test-requirements.txt
index 78e28b2..5a1e09d 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -5 +5 @@ hacking<0.12,>=0.11.0 # Apache-2.0
-coverage>=3.6 # Apache-2.0
+coverage>=4.0 # Apache-2.0
@@ -8 +8 @@ fixtures>=3.0.0 # Apache-2.0/BSD
-requests-mock>=1.0 # Apache-2.0
+requests-mock>=1.1 # Apache-2.0
@@ -11,2 +11,2 @@ Babel>=2.3.4 # BSD
-oslosphinx!=3.4.0,>=2.5.0 # Apache-2.0
-reno>=1.8.0 # Apache2
+oslosphinx>=4.7.0 # Apache-2.0
+reno>=1.8.0 # Apache-2.0
@@ -15 +15 @@ python-subunit>=0.0.18 # Apache-2.0/BSD
-sphinx!=1.3b1,<1.3,>=1.2.1 # BSD
+sphinx!=1.3b1,<1.4,>=1.2.1 # BSD
@@ -18,2 +18 @@ tempest>=12.1.0 # Apache-2.0
-os-testr>=0.7.0 # Apache-2.0
-jsonschema!=2.5.0,<3.0.0,>=2.0.0 # MIT
+os-testr>=0.8.0 # Apache-2.0


OpenStack-announce mailing list
OpenStack-announce@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-announce
asked Nov 8, 2016 in openstack-announce by no-reply_at_openstac (33,960 points)   2 17 46
...