settingsLogin | Registersettings

[openstack-announce] [new][puppet] puppet-ec2api 10.0.0 release (ocata)

0 votes

We are tickled pink to announce the release of:

puppet-ec2api 10.0.0: Puppet module for OpenStack Ec2api

This is the first release of puppet-ec2api. This release is part of
the ocata release series.

Download the package from:

https://tarballs.openstack.org/puppet-ec2api/

For more details, please see below.

Changes in puppet-ec2api ae25d3d74c37a54c089fb90fe4341605389566c7..10.0.0


64f8b0c Prepare 10.0.0 release
085d8cc Add requirements in metadata.json file
256448c Update test of policy
ed10140 Add support for dbmaxretries param
327033a Change worker defaults to ::osworkers
d00fa25 Fix documentation for log
dir parameter
8d86f56 remove duplicated lines. fix script name
d908564 Change version in conf
aa055ac Enable release notes translation
408a34c Changed the home-page to point Openstack Puppet Homepage
037413f Move rspec-puppet-facts to spec helper
f52c48b Added retries for dbsync
7344155 Fix authtoken
f80ddcf Fix metadata for authtoken
5af4c6a Remove S3 service
8274047 beaker: test more classes
2f7ebe9 Add basic structure for ReNo
2f00a82 Change authtoken to class
5987c23 Move Ec2Api to authtoken
7baa60f Include openstacklib defaults manifest.
ff506ca Add purge
config option
b085ac5 Add Xenial to metadata
1fca307 Update metadata
9ca1795 Add all other classes
ad894b5 Add db related classes
de16acd Add 3 api classes and params
b7560e3 Change wiki to docs
6ba14d1 Fix package version and remove useless arguments
98af828 Test multiple operating systems for ec2api::db::postgresql
02547a3 Add the capability to configure api-paste.ini with config.pp
35e81a7 Add basic unit tests + beaker
a718515 Add types, providers and unit tests
3c5d1a3 Changing default params for db/* and init.pp
1cf7966 Update Gemfile with openstackspechelper
925228e puppet-ec2api: Initial commit

Requirements updates


diff --git a/test-requirements.txt b/test-requirements.txt
new file mode 100644
index 0000000..bedd666
--- /dev/null
+++ b/test-requirements.txt
@@ -0,0 +1,4 @@
+# this is required for the docs build jobs
+sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
+oslosphinx>=2.5.0 # Apache-2.0
+reno>=0.1.1 # Apache-2.0


OpenStack-announce mailing list
OpenStack-announce@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-announce
asked Nov 18, 2016 in openstack-announce by no-reply_at_openstac (33,960 points)   2 14 30
...