settingsLogin | Registersettings

[Openstack-operators] OSA Newton Release Deployment in test environment

0 votes

Hi All,

I am trying to prepare test environment as mentioned in the following link.
I am using two VMs created in Virtualbox. One will be Infra Node and other
will be Compute Node. "Block Storage Host" is not present in my deployment.
http://docs.openstack.org/project-deploy-guide/openstack-ansible/newton/app-config-test.html#test-environment-config

While following instructions in Newton deployment guide (
http://docs.openstack.org/project-deploy-guide/openstack-ansible/newton/),
at "Run Playbooks" step, "openstack-ansible setup-hosts.yml" is successful
but "openstack-ansible setup-infrastructure.yml" is failing.

It is failing for " infra1repocontainer-" and is failing at "TASK
[pipinstall : Install apt packages] **************************************"
Here is the failure text:
failed: [infra1
repocontainer-f9649c00] (item=[u'build-essential',
u'python-setuptools', u'libffi-dev', u'libssl-dev', u'python-dev',
u'python-openssl', u'python-pyasn1']) => {"cache
updatetime": 0,
"cache
updated": false, "failed": true, "invocation": {"moduleargs":
{"allow
unauthenticated": false, "autoremove": false, "cachevalidtime":
null, "deb": null, "defaultrelease": null, "dpkgoptions":
"force-confdef,force-confold", "force": false, "installrecommends": null,
"name": ["build-essential", "python-setuptools", "libffi-dev",
"libssl-dev", "python-dev", "python-openssl", "python-pyasn1"],
"only
upgrade": false, "package": ["build-essential", "python-setuptools",
"libffi-dev", "libssl-dev", "python-dev", "python-openssl",
"python-pyasn1"], "purge": false, "state": "latest", "updatecache": false,
"upgrade": null}, "module
name": "apt"}, "item": ["build-essential",
"python-setuptools", "libffi-dev", "libssl-dev", "python-dev",
"python-openssl", "python-pyasn1"], "msg": "'/usr/bin/apt-get -y -o
\"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\"
install 'python-setuptools' 'python-openssl' 'python-pyasn1'' failed: E:
There are problems and -y was used without --force-yes\n", "stderr": "E:
There are problems and -y was used without --force-yes\n", "stdout":
"Reading package lists...\nBuilding dependency tree...\nReading state
information...\nThe following extra packages will be installed:\n
python-pkg-resources\nSuggested packages:\n python-openssl-doc
python-openssl-dbg python-distribute\n python-distribute-doc doc-base\nThe
following NEW packages will be installed:\n python-openssl
python-pkg-resources python-pyasn1 python-setuptools\n0 upgraded, 4 newly
installed, 0 to remove and 4 not upgraded.\nNeed to get 418 kB of
archives.\nAfter this operation, 1801 kB of additional disk space will be
used.\nWARNING: The following packages cannot be authenticated!\n
python-pkg-resources python-setuptools\n", "stdout_lines": ["Reading
package lists...", "Building dependency tree...", "Reading state
information...", "The following extra packages will be installed:", "
python-pkg-resources", "Suggested packages:", " python-openssl-doc
python-openssl-dbg python-distribute", " python-distribute-doc doc-base",
"The following NEW packages will be installed:", " python-openssl
python-pkg-resources python-pyasn1 python-setuptools", "0 upgraded, 4 newly
installed, 0 to remove and 4 not upgraded.", "Need to get 418 kB of
archives.", "After this operation, 1801 kB of additional disk space will be
used.", "WARNING: The following packages cannot be authenticated!", "
python-pkg-resources python-setuptools"]}

On looking around, it seems that it is happening because LXC are lacking
connectivity to internet. So, as per the link:
http://docs.openstack.org/developer/openstack-ansible/developer-docs/installation-hosts-limited-connectivity.html
I tried the step mentioned at this page under heading "Install pip through
deployment host" but it is giving following error.

"fatal: [infra1]: FAILED! => {"changed": true, "cmd": "python
/opt/get-pip.py --isolated --no-index --find-links=/tmp/pipinstall
pip==8.1.2 setuptools==28.6.0 wheel==0.29.0", "delta": "0:00:00.740516",
"end": "2017-02-04 22:58:12.985852", "failed": true, "invocation":
{"module
args": {"rawparams": "python /opt/get-pip.py --isolated
--no-index --find-links=/tmp/pipinstall pip==8.1.2 setuptools==28.6.0
wheel==0.29.0", "
usesshell": true, "chdir": null, "creates": null,
"executable": null, "removes": null, "warn": true}, "module
name":
"command"}, "rc": 1, "start": "2017-02-04 22:58:12.245336", "stderr": "Url
'/tmp/pipinstall' is ignored. It is either a non-existing path or lacks a
specific scheme.\n Url '/tmp/pip
install' is ignored. It is either a
non-existing path or lacks a specific scheme.\n Could not find a version
that satisfies the requirement setuptools==28.6.0 (from versions: )\nNo
matching distribution found for setuptools==28.6.0", "stdout": "Requirement
already up-to-date: pip==8.1.2 in
/usr/local/lib/python2.7/dist-packages\nCollecting setuptools==28.6.0",
"stdout_lines": ["Requirement already up-to-date: pip==8.1.2 in
/usr/local/lib/python2.7/dist-packages", "Collecting setuptools==28.6.0"],
"warnings": []}"

Please guide if you are aware of any solution to this problem.

Thanks.

Regards,
Amit


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
asked Feb 7, 2017 in openstack-operators by Amit_Kumar (980 points)   2 5 8

6 Responses

0 votes

Hi,

I am not an expert but I had similar problem and that was because of different MTU at host interface and container's interface.

My suggestion will be to check the MTU, if that helps.

Regards..
Salman.

PhD, Scientific Computing
Researcher, IT Department,
Uppsala University.
Senior Cloud Architect,
SNIC.
Cloud Application Expert,
UPPMAX.
salman.toor@it.uu.sehttps://mail.uu.se/owa/redir.aspx?REF=m0Eyh6bAe3V0K5jcrZeIkUVJw4_716jYUS9Yd1fJMFOsyyE71yXTCAFtYWlsdG86c2FsbWFuLnRvb3JAaXQudXUuc2U.
http://www.it.uu.se/katalog/salto690


From: Amit Kumar [ebiibe82@gmail.com]
Sent: Saturday, February 04, 2017 7:22 PM
To: openstack-operators@lists.openstack.org
Subject: [Openstack-operators] OSA Newton Release Deployment in test environment

Hi All,

I am trying to prepare test environment as mentioned in the following link. I am using two VMs created in Virtualbox. One will be Infra Node and other will be Compute Node. "Block Storage Host" is not present in my deployment.
http://docs.openstack.org/project-deploy-guide/openstack-ansible/newton/app-config-test.html#test-environment-config

While following instructions in Newton deployment guide (http://docs.openstack.org/project-deploy-guide/openstack-ansible/newton/), at "Run Playbooks" step, "openstack-ansible setup-hosts.yml" is successful but "openstack-ansible setup-infrastructure.yml" is failing.

It is failing for " infra1repocontainer-" and is failing at "TASK [pip_install : Install apt packages] **************************************"

Here is the failure text:
failed: [infra1repocontainer-f9649c00] (item=[u'build-essential', u'python-setuptools', u'libffi-dev', u'libssl-dev', u'python-dev', u'python-openssl', u'python-pyasn1']) => {"cacheupdatetime": 0, "cacheupdated": false, "failed": true, "invocation": {"moduleargs": {"allowunauthenticated": false, "autoremove": false, "cachevalidtime": null, "deb": null, "defaultrelease": null, "dpkgoptions": "force-confdef,force-confold", "force": false, "installrecommends": null, "name": ["build-essential", "python-setuptools", "libffi-dev", "libssl-dev", "python-dev", "python-openssl", "python-pyasn1"], "onlyupgrade": false, "package": ["build-essential", "python-setuptools", "libffi-dev", "libssl-dev", "python-dev", "python-openssl", "python-pyasn1"], "purge": false, "state": "latest", "updatecache": false, "upgrade": null}, "modulename": "apt"}, "item": ["build-essential", "python-setuptools", "libffi-dev", "libssl-dev", "python-dev", "python-openssl", "python-pyasn1"], "msg": "'/usr/bin/apt-get -y -o \"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\" install 'python-setuptools' 'python-openssl' 'python-pyasn1'' failed: E: There are problems and -y was used without --force-yes\n", "stderr": "E: There are problems and -y was used without --force-yes\n", "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nThe following extra packages will be installed:\n python-pkg-resources\nSuggested packages:\n python-openssl-doc python-openssl-dbg python-distribute\n python-distribute-doc doc-base\nThe following NEW packages will be installed:\n python-openssl python-pkg-resources python-pyasn1 python-setuptools\n0 upgraded, 4 newly installed, 0 to remove and 4 not upgraded.\nNeed to get 418 kB of archives.\nAfter this operation, 1801 kB of additional disk space will be used.\nWARNING: The following packages cannot be authenticated!\n python-pkg-resources python-setuptools\n", "stdoutlines": ["Reading package lists...", "Building dependency tree...", "Reading state information...", "The following extra packages will be installed:", " python-pkg-resources", "Suggested packages:", " python-openssl-doc python-openssl-dbg python-distribute", " python-distribute-doc doc-base", "The following NEW packages will be installed:", " python-openssl python-pkg-resources python-pyasn1 python-setuptools", "0 upgraded, 4 newly installed, 0 to remove and 4 not upgraded.", "Need to get 418 kB of archives.", "After this operation, 1801 kB of additional disk space will be used.", "WARNING: The following packages cannot be authenticated!", " python-pkg-resources python-setuptools"]}

On looking around, it seems that it is happening because LXC are lacking connectivity to internet. So, as per the link: http://docs.openstack.org/developer/openstack-ansible/developer-docs/installation-hosts-limited-connectivity.html
I tried the step mentioned at this page under heading "Install pip through deployment host" but it is giving following error.

"fatal: [infra1]: FAILED! => {"changed": true, "cmd": "python /opt/get-pip.py --isolated --no-index --find-links=/tmp/pipinstall pip==8.1.2 setuptools==28.6.0 wheel==0.29.0", "delta": "0:00:00.740516", "end": "2017-02-04 22:58:12.985852", "failed": true, "invocation": {"moduleargs": {"rawparams": "python /opt/get-pip.py --isolated --no-index --find-links=/tmp/pipinstall pip==8.1.2 setuptools==28.6.0 wheel==0.29.0", "usesshell": true, "chdir": null, "creates": null, "executable": null, "removes": null, "warn": true}, "modulename": "command"}, "rc": 1, "start": "2017-02-04 22:58:12.245336", "stderr": "Url '/tmp/pipinstall' is ignored. It is either a non-existing path or lacks a specific scheme.\n Url '/tmp/pipinstall' is ignored. It is either a non-existing path or lacks a specific scheme.\n Could not find a version that satisfies the requirement setuptools==28.6.0 (from versions: )\nNo matching distribution found for setuptools==28.6.0", "stdout": "Requirement already up-to-date: pip==8.1.2 in /usr/local/lib/python2.7/dist-packages\nCollecting setuptools==28.6.0", "stdout_lines": ["Requirement already up-to-date: pip==8.1.2 in /usr/local/lib/python2.7/dist-packages", "Collecting setuptools==28.6.0"], "warnings": []}"

Please guide if you are aware of any solution to this problem.

Thanks.

Regards,
Amit


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
responded Feb 4, 2017 by Salman_Toor (1,080 points)   1 7
0 votes

Thanks Salman. But in my case MTU sizes are same.

Anybody having any other opinion on this?

Regards,
Amit

On Sun, Feb 5, 2017 at 2:13 AM, Salman Toor salman.toor@it.uu.se wrote:

https://mail.uu.se/owa/?ae=PreFormAction&a=ReplyAll&t=IPM.Note&id=RgAAAAAYgm11jTMZSqDNQIKZhLPSBwCZtICTEb9DQLldDzcg6sC7AAAADML5AACZtICTEb9DQLldDzcg6sC7AABJX%2fCxAAAJ&pspid=_1486240160008_300721368#
Hi,

I am not an expert but I had similar problem and that was because of
different MTU at host interface and container's interface.

My suggestion will be to check the MTU, if that helps.

Regards..
Salman.

PhD, Scientific Computing
Researcher, IT Department,
Uppsala University.
Senior Cloud Architect,
SNIC.
Cloud Application Expert,
UPPMAX.
salman.toor@it.uu.se
https://mail.uu.se/owa/redir.aspx?REF=m0Eyh6bAe3V0K5jcrZeIkUVJw4_716jYUS9Yd1fJMFOsyyE71yXTCAFtYWlsdG86c2FsbWFuLnRvb3JAaXQudXUuc2U.
http://www.it.uu.se/katalog/salto690


From: Amit Kumar [ebiibe82@gmail.com]
Sent: Saturday, February 04, 2017 7:22 PM
To: openstack-operators@lists.openstack.org
Subject: [Openstack-operators] OSA Newton Release Deployment in test
environment

Hi All,

I am trying to prepare test environment as mentioned in the following
link. I am using two VMs created in Virtualbox. One will be Infra Node and
other will be Compute Node. "Block Storage Host" is not present in my
deployment.
http://docs.openstack.org/project-deploy-guide/
openstack-ansible/newton/app-config-test.html#test-environment-config

While following instructions in Newton deployment guide (
http://docs.openstack.org/project-deploy-guide/openstack-ansible/newton/),
at "Run Playbooks" step, "openstack-ansible setup-hosts.yml" is successful
but "openstack-ansible setup-infrastructure.yml" is failing.

It is failing for " infra1repocontainer-" and is failing at "TASK
[pipinstall : Install apt packages] ******************************
********"
Here is the failure text:
failed: [infra1
repocontainer-f9649c00] (item=[u'build-essential',
u'python-setuptools', u'libffi-dev', u'libssl-dev', u'python-dev',
u'python-openssl', u'python-pyasn1']) => {"cache
updatetime": 0,
"cache
updated": false, "failed": true, "invocation": {"moduleargs":
{"allow
unauthenticated": false, "autoremove": false, "cachevalidtime":
null, "deb": null, "defaultrelease": null, "dpkgoptions":
"force-confdef,force-confold", "force": false, "installrecommends": null,
"name": ["build-essential", "python-setuptools", "libffi-dev",
"libssl-dev", "python-dev", "python-openssl", "python-pyasn1"],
"only
upgrade": false, "package": ["build-essential", "python-setuptools",
"libffi-dev", "libssl-dev", "python-dev", "python-openssl",
"python-pyasn1"], "purge": false, "state": "latest", "updatecache": false,
"upgrade": null}, "module
name": "apt"}, "item": ["build-essential",
"python-setuptools", "libffi-dev", "libssl-dev", "python-dev",
"python-openssl", "python-pyasn1"], "msg": "'/usr/bin/apt-get -y -o
\"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\"
install 'python-setuptools' 'python-openssl' 'python-pyasn1'' failed: E:
There are problems and -y was used without --force-yes\n", "stderr": "E:
There are problems and -y was used without --force-yes\n", "stdout":
"Reading package lists...\nBuilding dependency tree...\nReading state
information...\nThe following extra packages will be installed:\n
python-pkg-resources\nSuggested packages:\n python-openssl-doc
python-openssl-dbg python-distribute\n python-distribute-doc doc-base\nThe
following NEW packages will be installed:\n python-openssl
python-pkg-resources python-pyasn1 python-setuptools\n0 upgraded, 4 newly
installed, 0 to remove and 4 not upgraded.\nNeed to get 418 kB of
archives.\nAfter this operation, 1801 kB of additional disk space will be
used.\nWARNING: The following packages cannot be authenticated!\n
python-pkg-resources python-setuptools\n", "stdout_lines": ["Reading
package lists...", "Building dependency tree...", "Reading state
information...", "The following extra packages will be installed:", "
python-pkg-resources", "Suggested packages:", " python-openssl-doc
python-openssl-dbg python-distribute", " python-distribute-doc doc-base",
"The following NEW packages will be installed:", " python-openssl
python-pkg-resources python-pyasn1 python-setuptools", "0 upgraded, 4 newly
installed, 0 to remove and 4 not upgraded.", "Need to get 418 kB of
archives.", "After this operation, 1801 kB of additional disk space will be
used.", "WARNING: The following packages cannot be authenticated!", "
python-pkg-resources python-setuptools"]}

On looking around, it seems that it is happening because LXC are lacking
connectivity to internet. So, as per the link: http://docs.openstack.org/
developer/openstack-ansible/developer-docs/installation-
hosts-limited-connectivity.html
I tried the step mentioned at this page under heading "Install pip
through deployment host" but it is giving following error.

"fatal: [infra1]: FAILED! => {"changed": true, "cmd": "python
/opt/get-pip.py --isolated --no-index --find-links=/tmp/pipinstall
pip==8.1.2 setuptools==28.6.0 wheel==0.29.0", "delta": "0:00:00.740516",
"end": "2017-02-04 22:58:12.985852", "failed": true, "invocation":
{"module
args": {"rawparams": "python /opt/get-pip.py --isolated
--no-index --find-links=/tmp/pipinstall pip==8.1.2 setuptools==28.6.0
wheel==0.29.0", "
usesshell": true, "chdir": null, "creates": null,
"executable": null, "removes": null, "warn": true}, "module
name":
"command"}, "rc": 1, "start": "2017-02-04 22:58:12.245336", "stderr": "Url
'/tmp/pipinstall' is ignored. It is either a non-existing path or lacks a
specific scheme.\n Url '/tmp/pip
install' is ignored. It is either a
non-existing path or lacks a specific scheme.\n Could not find a version
that satisfies the requirement setuptools==28.6.0 (from versions: )\nNo
matching distribution found for setuptools==28.6.0", "stdout": "Requirement
already up-to-date: pip==8.1.2 in /usr/local/lib/python2.7/dist-packages\nCollecting
setuptools==28.6.0", "stdout_lines": ["Requirement already up-to-date:
pip==8.1.2 in /usr/local/lib/python2.7/dist-packages", "Collecting
setuptools==28.6.0"], "warnings": []}"

Please guide if you are aware of any solution to this problem.

Thanks.

Regards,
Amit


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
responded Feb 6, 2017 by Amit_Kumar (980 points)   2 5 8
0 votes

On Sat, Feb 04, 2017 at 11:52:10PM +0530, Amit Kumar wrote:
Hi All,

used.\nWARNING: The following packages cannot be authenticated!\n

dpkg/apt are telling you what the problem is, go to the server and fix
apt

python-pkg-resources python-setuptools\n", "stdout_lines": ["Reading
package lists...", "Building dependency tree...", "Reading state
information...", "The following extra packages will be installed:", "
python-pkg-resources", "Suggested packages:", " python-openssl-doc
python-openssl-dbg python-distribute", " python-distribute-doc doc-base",
"The following NEW packages will be installed:", " python-openssl
python-pkg-resources python-pyasn1 python-setuptools", "0 upgraded, 4 newly
installed, 0 to remove and 4 not upgraded.", "Need to get 418 kB of
archives.", "After this operation, 1801 kB of additional disk space will be

used.", "WARNING: The following packages cannot be authenticated!", "
python-pkg-resources python-setuptools"]}
same error again

--
1AE0 322E B8F7 4717 BDEA BF1D 44BB 1BA7 9F6C 6333

keybase: https://keybase.io/gfa


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
responded Feb 6, 2017 by gustavo_panizzo_(gfa (3,080 points)   2 2
0 votes

Error is because LXC repo container on infra node is not having
connectivity to internet and is unable to download these packages. Thing is
that why containers are not having connectivity to internet whereas infra
node is having connectivity to internet.

Any idea if this is a general behavior that LXC containers are not able to
reach internet?

On Mon, Feb 6, 2017 at 1:39 PM, gustavo panizzo gfa@zumbi.com.ar wrote:

On Sat, Feb 04, 2017 at 11:52:10PM +0530, Amit Kumar wrote:

Hi All,

used.\nWARNING: The following packages cannot be authenticated!\n

dpkg/apt are telling you what the problem is, go to the server and fix
apt

python-pkg-resources python-setuptools\n", "stdout_lines": ["Reading
package lists...", "Building dependency tree...", "Reading state
information...", "The following extra packages will be installed:", "
python-pkg-resources", "Suggested packages:", " python-openssl-doc
python-openssl-dbg python-distribute", " python-distribute-doc doc-base",
"The following NEW packages will be installed:", " python-openssl
python-pkg-resources python-pyasn1 python-setuptools", "0 upgraded, 4
newly
installed, 0 to remove and 4 not upgraded.", "Need to get 418 kB of
archives.", "After this operation, 1801 kB of additional disk space will
be

used.", "WARNING: The following packages cannot be authenticated!", "
python-pkg-resources python-setuptools"]}
same error again

--
1AE0 322E B8F7 4717 BDEA BF1D 44BB 1BA7 9F6C 6333

keybase: https://keybase.io/gfa


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
responded Feb 6, 2017 by Amit_Kumar (980 points)   2 5 8
0 votes

LXC will setup eth0 in the container which will NAT through the host to access the internet.

Clearly there’s something wrong with that traffic path, so step through it like you would with any environment by validating that it is able to reach its gateway (host), then next hop, etc.

From: Amit Kumar ebiibe82@gmail.com
Date: Monday, February 6, 2017 at 8:17 AM
To: gustavo panizzo gfa@zumbi.com.ar
Cc: "openstack-operators@lists.openstack.org" openstack-operators@lists.openstack.org
Subject: Re: [Openstack-operators] OSA Newton Release Deployment in test environment

Error is because LXC repo container on infra node is not having connectivity to internet and is unable to download these packages. Thing is that why containers are not having connectivity to internet whereas infra node is having connectivity to internet.

Any idea if this is a general behavior that LXC containers are not able to reach internet?

On Mon, Feb 6, 2017 at 1:39 PM, gustavo panizzo gfa@zumbi.com.ar wrote:
On Sat, Feb 04, 2017 at 11:52:10PM +0530, Amit Kumar wrote:
Hi All,

used.\nWARNING: The following packages cannot be authenticated!\n

dpkg/apt are telling you what the problem is, go to the server and fix
apt

python-pkg-resources python-setuptools\n", "stdout_lines": ["Reading
package lists...", "Building dependency tree...", "Reading state
information...", "The following extra packages will be installed:", "
python-pkg-resources", "Suggested packages:", " python-openssl-doc
python-openssl-dbg python-distribute", " python-distribute-doc doc-base",
"The following NEW packages will be installed:", " python-openssl
python-pkg-resources python-pyasn1 python-setuptools", "0 upgraded, 4 newly
installed, 0 to remove and 4 not upgraded.", "Need to get 418 kB of
archives.", "After this operation, 1801 kB of additional disk space will be

used.", "WARNING: The following packages cannot be authenticated!", "
python-pkg-resources python-setuptools"]}
same error again

--
1AE0 322E B8F7 4717 BDEA BF1D 44BB 1BA7 9F6C 6333

keybase: https://keybase.io/gfa


Rackspace Limited is a company registered in England & Wales (company registered number 03897010) whose registered office is at 5 Millington Road, Hyde Park Hayes, Middlesex UB3 4AZ. Rackspace Limited privacy policy can be viewed at www.rackspace.co.uk/legal/privacy-policy - This e-mail message may contain confidential or privileged information intended for the recipient. Any dissemination, distribution or copying of the enclosed material is prohibited. If you receive this transmission in error, please notify us immediately by e-mail at abuse@rackspace.com and delete the original message. Your cooperation is appreciated.

OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
responded Feb 6, 2017 by Jesse.Pretorius_at_r (2,260 points)   1 2
0 votes

Thanks to all for your responses.

It is resolved. Actually, I am installing Infra and Compute on my
virtualbox VMs. Both these VMs are having NAT adapter and this was giving
IP to VM in the same subnet as was being assigned to containers in Infra
node. Ultimately, routing rules at Infra node were conflicting. Changed the
subnet of NAT adapter of my Infra VM and it worked.

Regards,
Amit

On Feb 6, 2017 11:52 PM, "Jesse Pretorius" Jesse.Pretorius@rackspace.co.uk
wrote:

LXC will setup eth0 in the container which will NAT through the host to
access the internet.

Clearly there’s something wrong with that traffic path, so step through it
like you would with any environment by validating that it is able to reach
its gateway (host), then next hop, etc.

*From: *Amit Kumar ebiibe82@gmail.com
*Date: *Monday, February 6, 2017 at 8:17 AM
*To: *gustavo panizzo gfa@zumbi.com.ar
*Cc: *"openstack-operators@lists.openstack.org" <
openstack-operators@lists.openstack.org>
*Subject: *Re: [Openstack-operators] OSA Newton Release Deployment in
test environment

Error is because LXC repo container on infra node is not having
connectivity to internet and is unable to download these packages. Thing is
that why containers are not having connectivity to internet whereas infra
node is having connectivity to internet.

Any idea if this is a general behavior that LXC containers are not able to
reach internet?

On Mon, Feb 6, 2017 at 1:39 PM, gustavo panizzo gfa@zumbi.com.ar wrote:

On Sat, Feb 04, 2017 at 11:52:10PM +0530, Amit Kumar wrote:

Hi All,

used.\nWARNING: The following packages cannot be authenticated!\n

dpkg/apt are telling you what the problem is, go to the server and fix
apt

python-pkg-resources python-setuptools\n", "stdout_lines": ["Reading
package lists...", "Building dependency tree...", "Reading state
information...", "The following extra packages will be installed:", "
python-pkg-resources", "Suggested packages:", " python-openssl-doc
python-openssl-dbg python-distribute", " python-distribute-doc doc-base",
"The following NEW packages will be installed:", " python-openssl
python-pkg-resources python-pyasn1 python-setuptools", "0 upgraded, 4
newly
installed, 0 to remove and 4 not upgraded.", "Need to get 418 kB of
archives.", "After this operation, 1801 kB of additional disk space will
be

used.", "WARNING: The following packages cannot be authenticated!", "
python-pkg-resources python-setuptools"]}
same error again

--
1AE0 322E B8F7 4717 BDEA BF1D 44BB 1BA7 9F6C 6333

keybase: https://keybase.io/gfa


Rackspace Limited is a company registered in England & Wales (company
registered number 03897010) whose registered office is at 5 Millington
Road, Hyde Park Hayes, Middlesex UB3 4AZ. Rackspace Limited privacy policy
can be viewed at www.rackspace.co.uk/legal/privacy-policy - This e-mail
message may contain confidential or privileged information intended for the
recipient. Any dissemination, distribution or copying of the enclosed
material is prohibited. If you receive this transmission in error, please
notify us immediately by e-mail at abuse@rackspace.com and delete the
original message. Your cooperation is appreciated.


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
responded Feb 7, 2017 by Amit_Kumar (980 points)   2 5 8
...