settingsLogin | Registersettings

Re: [Openstack-operators] Help- Errors Restarting Nova on Openstack Liberty environment

0 votes

Dear Openstack Users,

Awaiting your kind response please!
Our environment is in hanged situation because of above mentioned issue.

On Thu, Apr 6, 2017 at 1:32 PM, Gurpreet Thind gurpreet.thind@cenx.com
wrote:

Hi Openstack Operators,

We wanted to install gnocchi on our openstack environment(Liberty). It was
suppose to be a simple install but it also updated other libraries. Because
of which now our Nova component (API, Compute,Conductor, ConsoleAuth,
scheduler etc.) are not working. We are facing the Error: Exception:
Versioning for this project requires either an sdist tarball, or access to
an upstream git repository. Are you sure that git is installed?
Could you please help. I have attached the detailed simulation of the
steps and provided the logs. please assist.

We no longer want Gnocchi, we want to revert back our system to the
previous state.

—————————Detailed Information —————————————

*—— We have upgraded pip and installed Gnocchi. *

pip install gnocchi

—— On installing gnocchi the following files got updated.

gnocchi in /usr/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): cotyledon>=1.5.0
in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): PasteDeploy in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
oslo.middleware>=3.22.0 in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): pandas>=0.18.0
in /usr/lib64/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): ujson in
/usr/lib64/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): jsonpatch in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): numpy>=1.9.0 in
/usr/lib64/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): six in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
oslo.utils>=3.18.0 in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): werkzeug in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): WebOb>=1.4.1 in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): voluptuous in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): trollius;
pythonversion < "3.4" in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
oslo.serialization>=1.4.0 in /usr/lib/python2.7/site-packages (from
gnocchi)
Requirement already satisfied (use --upgrade to upgrade): Paste in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): iso8601 in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
oslo.config>=2.7.0 in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): pbr in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): futures in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): tenacity>=3.1.0
in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): stevedore in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): oslo.log>=2.3.0
in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
oslo.policy>=0.3.0 in /usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): pecan>=0.9 in
/usr/lib/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): scipy>=0.18.1 in
/usr/lib64/python2.7/site-packages (from gnocchi)
Requirement already satisfied (use --upgrade to upgrade): setproctitle;
sys
platform != "win32" in /usr/lib64/python2.7/site-packages (from
cotyledon>=1.5.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): statsd>=3.2.1 in
/usr/lib/python2.7/site-packages (from oslo.middleware>=3.22.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): oslo.i18n>=2.1.0
in /usr/lib/python2.7/site-packages (from oslo.middleware>=3.22.0->
gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
debtcollector>=1.2.0 in /usr/lib/python2.7/site-packages (from
oslo.middleware>=3.22.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
oslo.context>=2.12.0 in /usr/lib/python2.7/site-packages (from
oslo.middleware>=3.22.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
Jinja2!=2.9.0,!=2.9.1,!=2.9.2,!=2.9.3,!=2.9.4,>=2.8 in
/usr/lib/python2.7/site-packages (from oslo.middleware>=3.22.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): python-dateutil
in /usr/lib/python2.7/site-packages (from pandas>=0.18.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): pytz>=2011k in
/usr/lib/python2.7/site-packages (from pandas>=0.18.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): jsonpointer>=1.0
in /usr/lib/python2.7/site-packages (from jsonpatch->gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
netifaces>=0.10.4 in /usr/lib64/python2.7/site-packages (from
oslo.utils>=3.18.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): funcsigs>=0.4;
pythonversion == "2.7" or pythonversion == "2.6" in
/usr/lib/python2.7/site-packages (from oslo.utils>=3.18.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): monotonic>=0.6
in /usr/lib/python2.7/site-packages (from oslo.utils>=3.18.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
netaddr!=0.7.16,>=0.7.13 in /usr/lib/python2.7/site-packages (from
oslo.utils>=3.18.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): pyparsing>=2.1.0
in /usr/lib/python2.7/site-packages (from oslo.utils>=3.18.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
setuptools>=0.6b1 in /usr/lib/python2.7/site-packages (from
voluptuous->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): rfc3986>=0.3.1
in /usr/lib/python2.7/site-packages (from oslo.config>=2.7.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
pyinotify>=0.9.6; sysplatform != "win32" and sysplatform != "darwin" and
sys_platform != "sunos5" in /usr/lib/python2.7/site-packages (from
oslo.log>=2.3.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): Mako>=0.4.0 in
/usr/lib/python2.7/site-packages (from pecan>=0.9->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): WebTest>=1.3.1
in /usr/lib/python2.7/site-packages (from pecan>=0.9->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): logutils>=0.3 in
/usr/lib/python2.7/site-packages (from pecan>=0.9->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): singledispatch
in /usr/lib/python2.7/site-packages (from pecan>=0.9->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): wrapt>=1.7.0 in
/usr/lib64/python2.7/site-packages (from debtcollector>=1.2.0->oslo.
middleware>=3.22.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade):
positional>=1.1.1 in /usr/lib/python2.7/site-packages (from
oslo.context>=2.12.0->oslo.middleware>=3.22.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe>=0.23
in /usr/lib64/python2.7/site-packages (from Jinja2!=2.9.0,!=2.9.1,!=2.9.2,
!=2.9.3,!=2.9.4,>=2.8->oslo.middleware>=3.22.0->gnocchi)
Requirement already satisfied (use --upgrade to upgrade): appdirs>=1.4.0
in /usr/lib/python2.7/site-packages (from setuptools>=0.6b1->voluptuous-

gnocchi)
Requirement already satisfied (use --upgrade to upgrade): packaging>=16.8
in /usr/lib/python2.7/site-packages (from setuptools>=0.6b1->voluptuous-
gnocchi)

*——As a result our Nova-API went to activating state and struck forever. *

MainPID=9477 Id=neutron-dhcp-agent.service ActiveState=active
MainPID=9474 Id=neutron-l3-agent.service ActiveState=active
MainPID=4437 Id=neutron-metadata-agent.service ActiveState=active
MainPID=9476 Id=neutron-openvswitch-agent.service ActiveState=active
MainPID=4486 Id=neutron-server.service ActiveState=active
MainPID=50278 Id=openstack-ceilometer-alarm-evaluator.service
ActiveState=active
MainPID=53519 Id=openstack-ceilometer-alarm-notifier.service
ActiveState=active
MainPID=51340 Id=openstack-ceilometer-api.service ActiveState=active
MainPID=4510 Id=openstack-ceilometer-central.service ActiveState=active
MainPID=53991 Id=openstack-ceilometer-collector.service ActiveState=active
MainPID=50042 Id=openstack-ceilometer-compute.service ActiveState=active
MainPID=53990 Id=openstack-ceilometer-notification.service
ActiveState=active
MainPID=4500 Id=openstack-cinder-api.service ActiveState=active
MainPID=4429 Id=openstack-cinder-backup.service ActiveState=active
MainPID=4514 Id=openstack-cinder-scheduler.service ActiveState=active
MainPID=4488 Id=openstack-cinder-volume.service ActiveState=active
MainPID=4475 Id=openstack-glance-api.service ActiveState=active
MainPID=4496 Id=openstack-glance-registry.service ActiveState=active
MainPID=4497 Id=openstack-heat-api-cfn.service ActiveState=active
MainPID=59175 Id=openstack-heat-api.service ActiveState=active
MainPID=9893 Id=openstack-heat-engine.service ActiveState=active
MainPID=150584 Id=openstack-nova-api.service ActiveState=activating
MainPID=150585 Id=openstack-nova-cert.service ActiveState=activating
MainPID=150581 Id=openstack-nova-compute.service ActiveState=activating
MainPID=150582 Id=openstack-nova-conductor.service ActiveState=activating
MainPID=150580 Id=openstack-nova-consoleauth.service
ActiveState=activating
MainPID=0 Id=openstack-nova-novncproxy.service ActiveState=failed
MainPID=150583 Id=openstack-nova-scheduler.service ActiveState=activating

[root@OSKVM1 ~]# openstack-service status | grep nova
MainPID=152080 Id=openstack-nova-api.service ActiveState=activating
MainPID=152078 Id=openstack-nova-cert.service ActiveState=activating
MainPID=152081 Id=openstack-nova-compute.service ActiveState=activating
MainPID=152077 Id=openstack-nova-conductor.service ActiveState=activating
MainPID=152079 Id=openstack-nova-consoleauth.service
ActiveState=activating
MainPID=0 Id=openstack-nova-novncproxy.service ActiveState=failed
MainPID=152082 Id=openstack-nova-scheduler.service ActiveState=activating

*——Here are the Error we are getting: *

Apr 06 13:21:39 OSKVM1 systemd[1]: Unit openstack-nova-consoleauth.service
entered failed state.
Apr 06 13:21:39 OSKVM1 systemd[1]: openstack-nova-consoleauth.service
failed.
Apr 06 13:21:39 OSKVM1 systemd[1]: openstack-nova-compute.service holdoff
time over, scheduling restart.
Apr 06 13:21:39 OSKVM1 systemd[1]: Starting OpenStack Nova Compute
Server...
-- Subject: Unit openstack-nova-compute.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-compute.service has begun starting up.
Apr 06 13:21:39 OSKVM1 python2[155864]: detected unhandled Python
exception in '/usr/bin/nova-cert'
Apr 06 13:21:39 OSKVM1 python2[155782]: communication with ABRT daemon
failed: timed out
Apr 06 13:21:39 OSKVM1 python2[155782]: can't communicate with ABRT
daemon, is it running? local variable 'response' referenced before
assignment
Apr 06 13:21:39 OSKVM1 nova-api[155782]: Traceback (most recent call last):
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/bin/nova-api", line 6,
in
Apr 06 13:21:39 OSKVM1 nova-api[155782]: from nova.cmd.api import main
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/lib/python2.7/site-packages/nova/cmd/api.py",
line 25, in
Apr 06 13:21:39 OSKVM1 nova-api[155782]: from osloconfig import cfg
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/lib/python2.7/site-packages/oslo
config/cfg.py",
line 458, in
Apr 06 13:21:39 OSKVM1 nova-api[155782]: import debtcollector
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/lib/python2.7/site-
packages/debtcollector/init.py", line 20, in
Apr 06 13:21:39 OSKVM1 nova-api[155782]: 'debtcollector').versionstring()
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/lib/python2.7/site-packages/pbr/version.py",
line 457, in version
string
Apr 06 13:21:39 OSKVM1 nova-api[155782]: return
self.semanticversion().briefstring()
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/lib/python2.7/site-packages/pbr/version.py",
line 452, in semanticversion
Apr 06 13:21:39 OSKVM1 nova-api[155782]: self.
semantic =
self.getversionfrompkgresources()
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/lib/python2.7/site-packages/pbr/version.py",
line 439, in _get
versionfrompkgresources
Apr 06 13:21:39 OSKVM1 nova-api[155782]: result
string =
packaging.getversion(self.package)
Apr 06 13:21:39 OSKVM1 nova-api[155782]: File "/usr/lib/python2.7/site-packages/pbr/packaging.py",
line 668, in get
version
Apr 06 13:21:39 OSKVM1 nova-api[155782]: raise Exception("Versioning for
this project requires either an sdist"
Apr 06 13:21:39 OSKVM1 nova-api[155782]: Exception: Versioning for this
project requires either an sdist tarball, or access to an upstream git
repository. Are you sure that git is installed?
Apr 06 13:21:39 OSKVM1 systemd[1]: openstack-nova-api.service: main
process exited, code=exited, status=1/FAILURE
Apr 06 13:21:39 OSKVM1 systemd[1]: Failed to start OpenStack Nova API
Server.
-- Subject: Unit openstack-nova-api.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-api.service has failed.
--
-- The result is failed.

—— I Couldn’t find the Find the Fix for this issue, Please suggest how to
move further

Regards,
Gurpreet Thind


OpenStack-operators mailing list
OpenStack-operators@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
asked Apr 7, 2017 in openstack-operators by Gaurav_Goyal (340 points)   1 1
...