settingsLogin | Registersettings

[Openstack] TROVE: mongodb/cluster grow issue

0 votes

Hi

with mongodb(3.2)/cluster deployed with Trove/Ocata, when I try to grow
the initial cluster, I get some weird error:

trove cluster-grow baca7b0f-a68f-4fdd-b1bf-79c3d11d70fb --instance
"name=extra1,flavor=2x2048x25,volume=1,type=replica,relatedto=rs1"
ERROR: b"The value [u'replica'] for key type is invalid. Allowed values
are ['replica', 'query
router']. (HTTP 400)"

Any ideas?

Thanks,
J.


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
asked Jul 19, 2017 in openstack by magicboiz_at_gmail.c (160 points)  

2 Responses

0 votes

That’s not right, can you make a bug report here? https://bugs.launchpad.net/trove/

From: magicboiz@gmail.com [mailto:magicboiz@gmail.com]
Sent: Wednesday, July 19, 2017 7:43 AM
To: openstack@lists.openstack.org
Subject: [Openstack] TROVE: mongodb/cluster grow issue

Hi

with mongodb(3.2)/cluster deployed with Trove/Ocata, when I try to grow the initial cluster, I get some weird error:

trove cluster-grow baca7b0f-a68f-4fdd-b1bf-79c3d11d70fb --instance "name=extra1,flavor=2x2048x25,volume=1,type=replica,relatedto=rs1"
ERROR: b"The value [u'replica'] for key type is invalid. Allowed values are ['replica', 'query
router']. (HTTP 400)"

Any ideas?

Thanks,
J.


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
responded Jul 19, 2017 by MCCASLAND,_TREVOR (600 points)  
0 votes

https://bugs.launchpad.net/trove/+bug/1705412

tehere you are :)

On 19/07/17 16:15, MCCASLAND, TREVOR wrote:

That’s not right, can you make a bug report here?
https://bugs.launchpad.net/trove/

From:magicboiz@gmail.com [mailto:magicboiz@gmail.com]
Sent: Wednesday, July 19, 2017 7:43 AM
To: openstack@lists.openstack.org
Subject: [Openstack] TROVE: mongodb/cluster grow issue

Hi

with mongodb(3.2)/cluster deployed with Trove/Ocata, when I try to
grow the initial cluster, I get some weird error:

trove cluster-grow baca7b0f-a68f-4fdd-b1bf-79c3d11d70fb --instance
"name=extra1,flavor=2x2048x25,volume=1,type=replica,relatedto=rs1"
ERROR: b"The value [u'replica'] for key type is invalid. Allowed
values are ['replica', 'query
router']. (HTTP 400)"

Any ideas?

Thanks,
J.


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
responded Jul 20, 2017 by magicboiz_at_gmail.c (160 points)  
...