settingsLogin | Registersettings

[openstack-community] [openstack community] Nova api stopped working after a yum update (RDO - Ocata)

0 votes

Any request to the nova.api service at 8774 results in a error in
"/var/log/nova/nova-api.log".

A simple get request,

GET /v2.1/os-hypervisors/detail HTTP/1.1
Host: host.domain.com
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:54.0)
Gecko/20100101 Firefox/54.0
X-Auth-Token: XXXXXXXXXXXX
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
Accept-Language: en-US,en;q=0.5
Content-Type: application/json
Content-Length: 0
DNT: 1
Connection: close
Upgrade-Insecure-Requests: 1

Results in and error logged to "/var/log/nova/nova-api.log

WARNING keystoneauth.identity.generic.base [-] Discovering versions from
the identity service failed when creating the password plugin. Attempting
to determine version from URL.
ERROR nova.api.openstack [-] Caught error: Could not determine a suitable
URL for the plugin
ERROR nova.api.openstack Traceback (most recent call last):
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/nova/api/openstack/init.py", line 88,
in call
ERROR nova.api.openstack return req.getresponse(self.application)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/request.py", line 1299, in send
ERROR nova.api.openstack application, catch
excinfo=False)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/request.py", line 1263, in
call
application
ERROR nova.api.openstack appiter = application(self.environ,
start
response)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/dec.py", line 144, in call
ERROR nova.api.openstack return resp(environ, startresponse)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in call
ERROR nova.api.openstack resp = self.call
func(req, *args,
**self.kwargs)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
ERROR nova.api.openstack return self.func(req, *args, **kwargs)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/osprofiler/web.py", line 108, in __call__
ERROR nova.api.openstack return request.get_response(self.application)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/request.py", line 1299, in send
ERROR nova.api.openstack application, catch_exc_info=False)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/request.py", line 1263, in
call_application
ERROR nova.api.openstack app_iter = application(self.environ,
start_response)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
ERROR nova.api.openstack resp = self.call_func(req, *args,
**self.kwargs)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
ERROR nova.api.openstack return self.func(req, *args, **kwargs)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py",
line 332, in __call__
ERROR nova.api.openstack response = self.process_request(req)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py",
line 623, in process_request
ERROR nova.api.openstack resp = super(AuthProtocol,
self).process_request(request)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py",
line 405, in process_request
ERROR nova.api.openstack allow_expired=allow_expired)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py",
line 435, in _do_fetch_token
ERROR nova.api.openstack data = self.fetch_token(token, **kwargs)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py",
line 762, in fetch_token
ERROR nova.api.openstack allow_expired=allow_expired)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py",
line 217, in verify_token
ERROR nova.api.openstack auth_ref = self._request_strategy.verify_token(
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py",
line 168, in _request_strategy
ERROR nova.api.openstack strategy_class = self._get_strategy_class()
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py",
line 190, in _get_strategy_class
ERROR nova.api.openstack if
self._adapter.get_endpoint(version=klass.AUTH_VERSION):
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 176, in
get_endpoint
ERROR nova.api.openstack return self.session.get_endpoint(auth or
self.auth, **kwargs)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 856, in
get_endpoint
ERROR nova.api.openstack return auth.get_endpoint(self, **kwargs)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line
212, in get_endpoint
ERROR nova.api.openstack service_catalog =
self.get_access(session).service_catalog
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line
136, in get_access
ERROR nova.api.openstack self.auth_ref = self.get_auth_ref(session)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py",
line 196, in get_auth_ref
ERROR nova.api.openstack self._plugin = self._do_create_plugin(session)
ERROR nova.api.openstack File
"/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py",
line 191, in _do_create_plugin
ERROR nova.api.openstack raise exceptions.DiscoveryFailure('Could not
determine a suitable URL '
ERROR nova.api.openstack DiscoveryFailure: Could not determine a suitable
URL for the plugin
ERROR nova.api.openstack

Any request results in a smiler error. Am I possibly missing a "new"
configuration option in nova.conf or api-paste.in?

Here is a list of packages that where updated via yum update.

---> Package openstack-cinder.noarch 1:10.0.1-1.el7 will be updated
---> Package openstack-cinder.noarch 1:10.0.5-1.el7 will be an update
---> Package openstack-dashboard.noarch 1:11.0.1-2.el7 will be updated
---> Package openstack-dashboard.noarch 1:11.0.3-1.el7 will be an update
---> Package openstack-heat-api.noarch 1:8.0.1-1.el7 will be updated
---> Package openstack-heat-api.noarch 1:8.0.4-1.el7 will be an update
---> Package openstack-heat-api-cfn.noarch 1:8.0.1-1.el7 will be updated
---> Package openstack-heat-api-cfn.noarch 1:8.0.4-1.el7 will be an update
---> Package openstack-heat-common.noarch 1:8.0.1-1.el7 will be updated
---> Package openstack-heat-common.noarch 1:8.0.4-1.el7 will be an update
---> Package openstack-heat-engine.noarch 1:8.0.1-1.el7 will be updated
---> Package openstack-heat-engine.noarch 1:8.0.4-1.el7 will be an update
---> Package openstack-keystone.noarch 1:11.0.0-1.el7 will be updated
---> Package openstack-keystone.noarch 1:11.0.3-1.el7 will be an update
---> Package openstack-magnum-api.noarch 0:4.1.0-2.el7 will be updated
---> Package openstack-magnum-api.noarch 0:4.1.3-1.el7 will be an update
---> Package openstack-magnum-common.noarch 0:4.1.0-2.el7 will be updated
---> Package openstack-magnum-common.noarch 0:4.1.3-1.el7 will be an update
---> Package openstack-magnum-conductor.noarch 0:4.1.0-2.el7 will be updated
---> Package openstack-magnum-conductor.noarch 0:4.1.3-1.el7 will be an
update
---> Package openstack-neutron.noarch 1:10.0.1-1.el7 will be updated
---> Package openstack-neutron.noarch 1:10.0.3-1.el7 will be an update
---> Package openstack-neutron-common.noarch 1:10.0.1-1.el7 will be updated
---> Package openstack-neutron-common.noarch 1:10.0.3-1.el7 will be an
update
---> Package openstack-neutron-fwaas.noarch 1:10.0.1-1.el7 will be updated
---> Package openstack-neutron-fwaas.noarch 1:10.1.0-1.el7 will be an update
---> Package openstack-neutron-ml2.noarch 1:10.0.1-1.el7 will be updated
---> Package openstack-neutron-ml2.noarch 1:10.0.3-1.el7 will be an update
---> Package openstack-neutron-openvswitch.noarch 1:10.0.1-1.el7 will be
updated
---> Package openstack-neutron-openvswitch.noarch 1:10.0.3-1.el7 will be an
update
---> Package openstack-nova-api.noarch 1:15.0.3-2.el7 will be updated
---> Package openstack-nova-api.noarch 1:15.0.7-1.el7 will be an update
---> Package openstack-nova-common.noarch 1:15.0.3-2.el7 will be updated
---> Package openstack-nova-common.noarch 1:15.0.7-1.el7 will be an update
---> Package openstack-nova-conductor.noarch 1:15.0.3-2.el7 will be updated
---> Package openstack-nova-conductor.noarch 1:15.0.7-1.el7 will be an
update
---> Package openstack-nova-console.noarch 1:15.0.3-2.el7 will be updated
---> Package openstack-nova-console.noarch 1:15.0.7-1.el7 will be an update
---> Package openstack-nova-novncproxy.noarch 1:15.0.3-2.el7 will be updated
---> Package openstack-nova-novncproxy.noarch 1:15.0.7-1.el7 will be an
update
---> Package openstack-nova-placement-api.noarch 1:15.0.3-2.el7 will be
updated
---> Package openstack-nova-placement-api.noarch 1:15.0.7-1.el7 will be an
update
---> Package openstack-nova-scheduler.noarch 1:15.0.3-2.el7 will be updated
---> Package openstack-nova-scheduler.noarch 1:15.0.7-1.el7 will be an
update
---> Package openstack-selinux.noarch 0:0.7.13-2.el7 will be updated
---> Package openstack-selinux.noarch 0:0.8.7-1.el7 will be an update

Thanks,
Avery


Community mailing list
Community@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/community
asked Sep 26, 2017 in openstack-community by Avery_Rozar (200 points)  
...