settingsLogin | Registersettings

[openstack-dev] [networking-ovn] Error while running unit tests(master branch)

0 votes

Hi,

I just cloned the networking-ovn master branch and ran the unit tests.
I got the following ERROR:

tox

..........
{9}networkingovn.tests.unit.ovsdb.testovsdbmonitor.TestOvnConnection.testconnectionsbstart
[0.015743s] ... ok
Mechanism driver 'ovn' failed in createportprecommit
Traceback (most recent call last):
File "networking-ovn-orig/networking-ovn/.tox/py27/src/neutron/neutron/plugins/ml2/managers.py",
line 428, in callondrivers
getattr(driver.obj, method
name)(context)
File "networkingovn/ml2/mechdriver.py", line 325, in createportprecommit
utils.validateandgetdatafrombindingprofile(port)
File "networkingovn/common/utils.py", line 162, in
validate
andgetdatafrombindingprofile
raise n
exc.InvalidInput(error_message=msg)
InvalidInput: Invalid input for operation: Invalid binding:profile.
vtep-logical-switch 1234 value invalid type.

Is the test suite broken?.

Any ideas on how to fix it?

Thanks,
Pranab


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
asked Oct 24, 2017 in openstack-dev by pranab_boruah (740 points)   2 6

3 Responses

0 votes

Hi Pranab,

Thanks for the interest in OVN.

tox

..........
{9}networkingovn.tests.unit.ovsdb.testovsdbmonitor.TestOvnConnection.testconnectionsbstart
[0.015743s] ... ok
Mechanism driver 'ovn' failed in createportprecommit
Traceback (most recent call last):
File "networking-ovn-orig/networking-ovn/.tox/py27/src/neutron/neutron/plugins/ml2/managers.py",
line 428, in callondrivers
getattr(driver.obj, method
name)(context)
File "networkingovn/ml2/mechdriver.py", line 325, in createportprecommit
utils.validateandgetdatafrombindingprofile(port)
File "networkingovn/common/utils.py", line 162, in
validate
andgetdatafrombindingprofile
raise n
exc.InvalidInput(error_message=msg)
InvalidInput: Invalid input for operation: Invalid binding:profile.
vtep-logical-switch 1234 value invalid type.

Is the test suite broken?.

Any ideas on how to fix it?

So, not really sure what is going on there. I've just ran the
unit-tests (master branch) against a fresh environment using both
Python 2 and 3 interpreters and it finished successfully [0].

Could you please paste (at [1]) the whole output of the tests run for
us please ?

[0] http://paste.openstack.org/show/624353/
[1] http://paste.openstack.org/

Cheers,
Lucas


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
responded Oct 23, 2017 by Lucas_Alvares_Gomes (6,080 points)   1 2 3
0 votes

Thanks Lucas for the reply.

I don't see any errors in final results. But, as you can see here [1],
couple of tests are showing ERROR before that.

[1] http://paste.openstack.org/show/624436/

Regards,
Pranab


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
responded Oct 24, 2017 by pranab_boruah (740 points)   2 6
0 votes

Hi Pranab,

I don't see any errors in final results. But, as you can see here [1],
couple of tests are showing ERROR before that.

[1] http://paste.openstack.org/show/624436/

Ah, I see what you mean now. Off the top of my head I don't know what
is the cause, I will need to some troubleshooting. But, I can confirm
that I see the same errors by running the tests locally on my machine.

I have opened a bug against it at
https://bugs.launchpad.net/networking-ovn/+bug/1726845 so we can keep
track of the problem and to raise more awareness about it. The
importance was set to medium because the tests run still succeed
regardless of those exceptions being raised.

Thanks a lot of identifying and reporting this problem, hopefully we
can get it fixed soon!

Cheers,
Lucas


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
responded Oct 24, 2017 by Lucas_Alvares_Gomes (6,080 points)   1 2 3
...