settingsLogin | Registersettings

[openstack-dev] [Neutron] Infiniband & Melanox OFED 4.2 eIPoIB support

0 votes

Dear Neutron developers,

we are building up an OpenStack (Pike) cluster based on CentOS 7.4 and
Mellanox Ofed 4.2.
As far as we understand Neutron rely on eIPoIB in order to manage
Infiniband networks but unfortunately Mellanox dropped this feature for
the new OFED versions.
Here below the Mellanox support answer about that:

"Please note that as of Mellanox OFED 4.0 eIPoIB is no longer supported
in Mellanox OFED.If you wish to use it we recommend using the 3.4.X
Drivers which still supported this feature."

Obviously we can not use the 3.X version of OFED because is not
supported by RHEL 7.4 and also because we don't want to stick with an
old software version.
Do you have any plan to overcome this issue?

Thank you, regards

Massimo Benini


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
asked Nov 14, 2017 in openstack-dev by Massimo_Benini (120 points)  

1 Response

0 votes

This more question to mellanox then to neutron community.
I suggest that you will send me private mail regarding this issue and we can take it with the relevant people in Mellanox.
My email is moshele@mellanox.com.

-----Original Message-----
From: Massimo Benini [mailto:benini@cscs.ch]
Sent: Tuesday, November 14, 2017 11:39 AM
To: openstack-dev@lists.openstack.org
Subject: [openstack-dev] [Neutron] Infiniband & Melanox OFED 4.2 eIPoIB
support

Dear Neutron developers,

we are building up an OpenStack (Pike) cluster based on CentOS 7.4 and
Mellanox Ofed 4.2.
As far as we understand Neutron rely on eIPoIB in order to manage
Infiniband networks but unfortunately Mellanox dropped this feature for the
new OFED versions.
Here below the Mellanox support answer about that:

"Please note that as of Mellanox OFED 4.0 eIPoIB is no longer supported in
Mellanox OFED.If you wish to use it we recommend using the 3.4.X Drivers
which still supported this feature."

Obviously we can not use the 3.X version of OFED because is not supported
by RHEL 7.4 and also because we don't want to stick with an old software
version.
Do you have any plan to overcome this issue?

Thank you, regards

Massimo Benini



OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-
request@lists.openstack.org?subject:unsubscribe
https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Flists.
openstack.org%2Fcgi-bin%2Fmailman%2Flistinfo%2Fopenstack-
dev&data=02%7C01%7Cmoshele%40mellanox.com%7C6de1b0a14e4540045a
4108d52b434d35%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636
462490423586383&sdata=oEdi3vFeR4CEBom7rZNHajd%2BmujXhuHrT49yTx7
Q5Bk%3D&reserved=0

OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
responded Nov 14, 2017 by Moshe_Levi (2,920 points)   3 5
...