settingsLogin | Registersettings

[openstack-announce] [new][nova] python-novaclient 5.0.0 release (newton)

0 votes

We are joyful to announce the release of:

python-novaclient 5.0.0: Client library for OpenStack Compute API

This release is part of the newton release series.

With source available at:

https://git.openstack.org/cgit/openstack/python-novaclient

With package available at:

https://pypi.python.org/pypi/python-novaclient

Please report issues through launchpad:

https://bugs.launchpad.net/python-novaclient

For more details, please see below.

5.0.0
^^^^^

New Features


  • The 2.32 microverison adds support for virtual device role
    tagging. Device role tagging is an answer to the question 'Which
    device is which?' from inside the guest. When booting an instance,
    an optional arbitrary 'tag' parameter can be set on virtual network
    interfaces and/or block device mappings. This tag is exposed to the
    instance through the metadata API and on the config drive. Each
    tagged virtual network interface is listed along with information
    about the virtual hardware, such as bus type (ex: PCI), bus address
    (ex: 0000:00:02.0), and MAC address. For tagged block devices, the
    exposed hardware metadata includes the bus (ex: SCSI), bus address
    (ex: 1:0:2:0) and serial number.

    In the client, device tagging is exposed with the 'tag' key in the
    --block-device and --nic boot arguments.

Known Issues


  • While not an issue with the client itself, it should be noted that
    if a tagged network interface or volume is detached from a guest,
    its metadata will continue to appear in the config drive, even after
    instance reboot.

Upgrade Notes


  • Support for microversion 2.31 which fixes a bug in the os-console-
    auth-tokens API

  • novaclient.v2.client.Client raises an exception in case of direct
    usage instead of warning message. novaclient.client.Client is a
    primary interface to initialize the python client for Nova.

Deprecation Notes


  • The following CLIs and python API bindings are now deprecated for
    removal:

    • nova baremetal-node-list

    • nova baremetal-node-show

    • nova baremetal-interface-list

    These will be removed in the first major python-novaclient release
    after the Nova 15.0.0 Ocata release. Use python-ironicclient or
    python-openstackclient for CLI and python-ironicclient or
    openstacksdk for python API bindings.

Changes in python-novaclient 4.1.0..5.0.0


87c1b53 Deprecate baremetal API and CLI interfaces
598df4e Add a missing i18n support
8c1d8fb Correctly handle NOVACLIENTINESCURE
7fb0bd4 Virtual device tagging client support
e7f1bdb Update clouds.yaml.sample
423239c Updated from global requirements
55201c5 base.Resource not define ne() built-in function
58c46d6 Remove white space between print and ()
6f86679 Clean up deprecated CLI options
2ba578d functional: fix a deprecation warning in test
auth.TestAuthentication
f1b0683 functional: skip testauthviakeystonevX if X is not available
84f4e1e Raise an exception in v2.client for direct_use
5b28edd Add support for microversion 2.31
52be6ef Updated from global requirements
efc6ec5 Updated from global requirements
431e3e9 [functional] Fix wrong message in server description test
74c3da9 Deprecated the --volume-service-name option
0b2de53 Make it possible to list quotas with details
d6ca9e2 List system dependencies for running common tests
0c64947 make string.letters python3 compatible
e54d3a7 Updated from global requirements
7a24b0f Fix the help message for 'get-mks-console'
c649678 Add support for microversion 2.30
1aa042e Add support for microversion 2.29
d38882b Updated from global requirements
00013b2 [functional] make tests work with only keystone v3
e91a593 Updated from global requirements
5f63dee Update README to comply with Identity v3
f9bdba2 Extend microversion stuff to support resource classes

Diffstat (except docs and test files)


README.rst | 36 +--
novaclient/init.py | 2 +-
novaclient/apiversions.py | 37 ++-
novaclient/base.py | 7 +
novaclient/shell.py | 113 +-------
novaclient/utils.py | 10 -
novaclient/v2/client.py | 19 +-
novaclient/v2/contrib/baremetal.py | 40 ++-
novaclient/v2/contrib/host
evacuate.py | 18 +-
novaclient/v2/contrib/hostevacuatelive.py | 19 +-
novaclient/v2/quotas.py | 14 +-
novaclient/v2/servers.py | 191 ++++++++++----
novaclient/v2/shell.py | 290 +++++++--------------
other-requirements.txt | 23 ++
.../deprecate-baremetal-d67f58a2986b3565.yaml | 13 +
.../notes/microversion-v231-3e1a16eb5eb53f59.yaml | 4 +
.../notes/microversion-v2
32-7947430cc2415597.yaml | 25 ++
...eprecated-option-in-3.3.0-82a413157838570d.yaml | 53 ++++
...ct-direct-use-of-v2client-c8e1ee2afefec5a1.yaml | 5 +
requirements.txt | 4 +-
test-requirements.txt | 8 +-
tox.ini | 8 +
36 files changed, 988 insertions(+), 474 deletions(-)

Requirements updates


diff --git a/other-requirements.txt b/other-requirements.txt
new file mode 100644
index 0000000..da3ab7f
--- /dev/null
+++ b/other-requirements.txt
@@ -0,0 +1,23 @@
+# This is a cross-platform list tracking distribution packages needed by tests;
+# see http://docs.openstack.org/infra/bindep/ for additional information.
+
+build-essential [platform:dpkg]
+dbus-devel [platform:rpm]
+dbus-glib-devel [platform:rpm]
+gettext
+language-pack-en [platform:ubuntu]
+libdbus-1-dev [platform:dpkg]
+libdbus-glib-1-dev [platform:dpkg]
+libffi-dev [platform:dpkg]
+libffi-devel [platform:rpm]
+libuuid-devel [platform:rpm]
+locales [platform:debian]
+python-dev [platform:dpkg]
+python-devel [platform:rpm]
+python3-all-dev [platform:ubuntu !platform:ubuntu-precise]
+python3-dev [platform:dpkg]
+python3-devel [platform:fedora]
+python3.4 [platform:ubuntu-trusty]
+python3.5 [platform:ubuntu-xenial]
+python34-devel [platform:centos]
+uuid-dev [platform:dpkg]
diff --git a/requirements.txt b/requirements.txt
index 29825fc..c2b23f2 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -5 +5 @@ pbr>=1.6 # Apache-2.0
-keystoneauth1>=2.1.0 # Apache-2.0
+keystoneauth1>=2.7.0 # Apache-2.0
@@ -9 +9 @@ oslo.serialization>=1.10.0 # Apache-2.0
-oslo.utils>=3.11.0 # Apache-2.0
+oslo.utils>=3.15.0 # Apache-2.0
diff --git a/test-requirements.txt b/test-requirements.txt
index 3b12cb8..b63d28f 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -14,2 +14,2 @@ python-cinderclient!=1.7.0,!=1.7.1,>=1.6.0 # Apache-2.0
-requests-mock>=0.7.0 # Apache-2.0
-sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2 # BSD
+requests-mock>=1.0 # Apache-2.0
+sphinx!=1.3b1,<1.3,>=1.2.1 # BSD
@@ -21 +21 @@ testtools>=1.4.0 # MIT
-tempest>=11.0.0 # Apache-2.0
+tempest>=12.1.0 # Apache-2.0
@@ -24 +24 @@ tempest>=11.0.0 # Apache-2.0
-reno>=1.6.2 # Apache2
+reno>=1.8.0 # Apache2


OpenStack-announce mailing list
OpenStack-announce@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-announce
asked Jul 18, 2016 in openstack-announce by no-reply_at_openstac (33,960 points)   2 16 41
retagged Jan 26, 2017 by admin
...