settingsLogin | Registersettings

[Openstack] /usr/bin/keystone-wsgi-admin file not found

0 votes

Dear Team,

I am installing openstack mitaka on my debian machine.
I followed the steps mentioned in the user manual,

while I am trying to register the keystone service, I am getting 404 error
and the error log shows
/usr/bin/keystone-wsgi-admin file not found

I don't see the file anywhere in my machine

Please help

Thanks
Mathi


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
asked Aug 8, 2016 in openstack by Selvamani_Gandhimath (160 points)   1 1

5 Responses

0 votes

Hi,
keystone-wsgi-admin usually is in /usr/local/bin directory (not /usr/bin)
Check if you have it there.
Then check your apache configuration
(/etc/apache2/sites-available/wsgi-keystone.conf)
There is a line: WSGIScriptAlias / /usr/local/bin/keystone-wsgi-admin
Check that path is correct and you do have a file at that location.
Example of apache config you can find here:
https://github.com/openstack/keystone/blob/master/httpd/wsgi-keystone.conf
So I guess all you need to do is: correct an error in apache config and
restart the apache.

Kind regards, Kseniya

On Mon, Aug 8, 2016 at 1:41 PM, Selvamani Gandhimathi psgmathi@gmail.com
wrote:

Dear Team,

I am installing openstack mitaka on my debian machine.
I followed the steps mentioned in the user manual,

while I am trying to register the keystone service, I am getting 404 error
and the error log shows
/usr/bin/keystone-wsgi-admin file not found

I don't see the file anywhere in my machine

Please help

Thanks
Mathi


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/
openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/
openstack


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
responded Aug 8, 2016 by Kseniya_Tychkova (420 points)   1
0 votes

I could not find the file in the /usr/local/bin/ also,

What should I do
On Aug 8, 2016 4:43 PM, "Kseniya Tychkova" ktychkova@mirantis.com wrote:

Hi,
keystone-wsgi-admin usually is in /usr/local/bin directory (not
/usr/bin)
Check if you have it there.
Then check your apache configuration (/etc/apache2/sites-available/
wsgi-keystone.conf)
There is a line: WSGIScriptAlias / /usr/local/bin/keystone-wsgi-admin
Check that path is correct and you do have a file at that location.
Example of apache config you can find here: https://github.com/openstack/
keystone/blob/master/httpd/wsgi-keystone.conf
So I guess all you need to do is: correct an error in apache config and
restart the apache.

Kind regards, Kseniya

On Mon, Aug 8, 2016 at 1:41 PM, Selvamani Gandhimathi psgmathi@gmail.com
wrote:

Dear Team,

I am installing openstack mitaka on my debian machine.
I followed the steps mentioned in the user manual,

while I am trying to register the keystone service, I am getting 404
error and the error log shows
/usr/bin/keystone-wsgi-admin file not found

I don't see the file anywhere in my machine

Please help

Thanks
Mathi


Mailing list: http://lists.openstack.org/cgi
-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi
-bin/mailman/listinfo/openstack


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
responded Aug 8, 2016 by Selvamani_Gandhimath (160 points)   1 1
0 votes

Try to run "sudo which keystone-wsgi-admin"

On Mon, Aug 8, 2016 at 2:16 PM, Selvamani Gandhimathi psgmathi@gmail.com
wrote:

I could not find the file in the /usr/local/bin/ also,

What should I do
On Aug 8, 2016 4:43 PM, "Kseniya Tychkova" ktychkova@mirantis.com wrote:

Hi,
keystone-wsgi-admin usually is in /usr/local/bin directory (not
/usr/bin)
Check if you have it there.
Then check your apache configuration (/etc/apache2/sites-available/
wsgi-keystone.conf)
There is a line: WSGIScriptAlias / /usr/local/bin/keystone-wsgi-admin
Check that path is correct and you do have a file at that location.
Example of apache config you can find here:
https://github.com/openstack/keystone/blob/master/httpd/wsg
i-keystone.conf
So I guess all you need to do is: correct an error in apache config and
restart the apache.

Kind regards, Kseniya

On Mon, Aug 8, 2016 at 1:41 PM, Selvamani Gandhimathi <psgmathi@gmail.com

wrote:

Dear Team,

I am installing openstack mitaka on my debian machine.
I followed the steps mentioned in the user manual,

while I am trying to register the keystone service, I am getting 404
error and the error log shows
/usr/bin/keystone-wsgi-admin file not found

I don't see the file anywhere in my machine

Please help

Thanks
Mathi


Mailing list: http://lists.openstack.org/cgi
-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi
-bin/mailman/listinfo/openstack


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
responded Aug 8, 2016 by Kseniya_Tychkova (420 points)   1
0 votes

On Mon, Aug 08, 2016 at 04:11:12PM +0530, Selvamani Gandhimathi wrote:
Dear Team,

I am installing openstack mitaka on my debian machine.
I followed the steps mentioned in the user manual,

while I am trying to register the keystone service, I am getting 404 error
and the error log shows
/usr/bin/keystone-wsgi-admin file not found

I don't see the file anywhere in my machine

which repos are you using? whic debian release?

I have this

$ dpkg -L keystone |grep bin
/usr/bin
/usr/bin/keystone-all
/usr/bin/keystone-manage
/usr/bin/keystone-wsgi-admin
/usr/bin/keystone-wsgi-public

$ dpkg -l keystone
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-======================================-========================-========================-=================================================================================
ii keystone 2:9.0.0-2~bpo8+1 all OpenStack identity service

--
1AE0 322E B8F7 4717 BDEA BF1D 44BB 1BA7 9F6C 6333

keybase: http://keybase.io/gfa

responded Aug 8, 2016 by gustavo_panizzo_(gfa (3,080 points)   2 2
0 votes

Hi Mathi!

Can you please specify a link to the instructions you've followed?

Thoughts: keystone-wsgi-* scripts are generated by PBR, which is
required, but it must be run in order to make these files. If you follow
DevStack installation procedure, all magic is done for you.

Hint: simplest way to make DevStack working is runnig all DevStack
related actions as 'stack' user.

On 08.08.2016 13:41, Selvamani Gandhimathi wrote:
Dear Team,

I am installing openstack mitaka on my debian machine.
I followed the steps mentioned in the user manual,

while I am trying to register the keystone service, I am getting 404
error and the error log shows
/usr/bin/keystone-wsgi-admin file not found

I don't see the file anywhere in my machine

Please help

Thanks
Mathi


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack


Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack@lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
responded Aug 8, 2016 by Alexander_V_Makarov (900 points)   1 2
...