settingsLogin | Registersettings

[openstack-dev] [all] python 2.6 for clients

0 votes

Hi all,

I assumed that we still support py26 for clients, but then I saw 1
that removed corresponding tox environment from ironic client.

What's our take on that? Shouldn't clients still support Python 2.6?

/Ihar

asked Jan 9, 2015 in openstack-dev by Ihar_Hrachyshka (35,300 points)   3 9 16
retagged Mar 19, 2015

3 Responses

0 votes

On 01/09/2015 02:25 PM, Ihar Hrachyshka wrote:
Hi all,

I assumed that we still support py26 for clients, but then I saw [1]
that removed corresponding tox environment from ironic client.

What's our take on that? Shouldn't clients still support Python 2.6?

[1]:
https://github.com/openstack/ironic-python-agent/commit/d95a99d5d1a62ef5c085ce20ec07d960a3f23ac1

Indeed, clients are supposed to continue supporting 2.6 as mentioned here:

http://lists.openstack.org/pipermail/openstack-dev/2014-October/049111.html

Andreas
--
Andreas Jaeger aj@{suse.com,opensuse.org} Twitter/Identica: jaegerandi
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 N?rnberg, Germany
GF: Felix Imend?rffer, Jane Smithard, Jennifer Guild, Dilip Upmanyu,
Graham Norton, HRB 21284 (AG N?rnberg)
GPG fingerprint = 93A3 365E CE47 B889 DF7F FED1 389A 563C C272 A126

responded Jan 9, 2015 by Andreas_Jaeger (17,140 points)   2 3 4
0 votes

On 01/09/2015 02:33 PM, Andreas Jaeger wrote:
On 01/09/2015 02:25 PM, Ihar Hrachyshka wrote:

Hi all,

I assumed that we still support py26 for clients, but then I saw [1]
that removed corresponding tox environment from ironic client.

What's our take on that? Shouldn't clients still support Python 2.6?

[1]:
https://github.com/openstack/ironic-python-agent/commit/d95a99d5d1a62ef5c085ce20ec07d960a3f23ac1
Indeed, clients are supposed to continue supporting 2.6 as mentioned here:

http://lists.openstack.org/pipermail/openstack-dev/2014-October/049111.html

Andreas

OK, thanks. Reverting: https://review.openstack.org/#/c/146083/

responded Jan 9, 2015 by Ihar_Hrachyshka (35,300 points)   3 9 16
0 votes

On 01/09/2015 02:37 PM, Ihar Hrachyshka wrote:
On 01/09/2015 02:33 PM, Andreas Jaeger wrote:

On 01/09/2015 02:25 PM, Ihar Hrachyshka wrote:

Hi all,

I assumed that we still support py26 for clients, but then I saw [1]
that removed corresponding tox environment from ironic client.

What's our take on that? Shouldn't clients still support Python 2.6?

[1]:
https://github.com/openstack/ironic-python-agent/commit/d95a99d5d1a62ef5c085ce20ec07d960a3f23ac1

Indeed, clients are supposed to continue supporting 2.6 as mentioned
here:

http://lists.openstack.org/pipermail/openstack-dev/2014-October/049111.html

Andreas

OK, thanks. Reverting: https://review.openstack.org/#/c/146083/
Thanks you for your time folks, but this is not a client :) it's an
alternative ramdisk for Ironic.


OpenStack-dev mailing list
OpenStack-dev at lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
responded Jan 9, 2015 by Dmitry_Tantsur (18,080 points)   2 3 7
...