settingsLogin | Registersettings

[openstack-dev] [new][oslo] oslo.versionedobjects 1.18.0 release (ocata)

0 votes

We are jubilant to announce the release of:

oslo.versionedobjects 1.18.0: Oslo Versioned Objects library

This release is part of the ocata release series.

The source is available from:

http://git.openstack.org/cgit/openstack/oslo.versionedobjects

Download the package from:

https://pypi.python.org/pypi/oslo.versionedobjects

Please report issues through launchpad:

http://bugs.launchpad.net/oslo.versionedobjects

For more details, please see below.

Changes in oslo.versionedobjects 1.17.0..1.18.0


0b79285 Changed the home-page link
8dd102e Updated from global requirements
4c4bd65 Changed the home-page link
98b7be2 Updated from global requirements
5b44faf JSON Schema get_schema implementation for last few fields
b9a38b4 Updated from global requirements
f351948 Add ObjectListBase concat methods
f79b434 Fix documentation typo
020dd5d Fix incorrect timestamp comment
7f0edcd Updated from global requirements

Diffstat (except docs and test files)


osloversionedobjects/utils.py | 2 +-
osloversionedobjects/base.py | 58 +++----
oslo
versionedobjects/fields.py | 60 +++++++-
requirements.txt | 8 +-
setup.cfg | 2 +-
test-requirements.txt | 5 +-
9 files changed, 337 insertions(+), 77 deletions(-)

Requirements updates


diff --git a/requirements.txt b/requirements.txt
index 8e986e4..3cdae51 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -7 +7 @@ oslo.config>=3.14.0 # Apache-2.0
-oslo.context>=2.6.0 # Apache-2.0
+oslo.context>=2.9.0 # Apache-2.0
@@ -12 +12 @@ iso8601>=0.1.11 # MIT
-oslo.log>=1.14.0 # Apache-2.0
+oslo.log>=3.11.0 # Apache-2.0
@@ -14,2 +14,2 @@ oslo.i18n>=2.1.0 # Apache-2.0
-WebOb>=1.2.3 # MIT
-netaddr!=0.7.16,>=0.7.12 # BSD
+WebOb>=1.6.0 # MIT
+netaddr!=0.7.16,>=0.7.13 # BSD
diff --git a/test-requirements.txt b/test-requirements.txt
index b30d301..26ef9bc 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -8,2 +8,2 @@ testtools>=1.4.0 # MIT
-oslosphinx!=3.4.0,>=2.5.0 # Apache-2.0
-sphinx!=1.3b1,<1.3,>=1.2.1 # BSD
+oslosphinx>=4.7.0 # Apache-2.0
+sphinx!=1.3b1,<1.4,>=1.2.1 # BSD
@@ -11,0 +12 @@ coverage>=3.6 # Apache-2.0
+jsonschema>=2.0.0,<3.0.0,!=2.5.0 # MIT


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
asked Oct 19, 2016 in openstack-dev by no-reply_at_openstac (33,960 points)   2 14 32
retagged Jan 26, 2017 by admin
...