settingsLogin | Registersettings

[openstack-dev] [devstack][mitaka] Unable stack.sh on ubuntu 14.04.5LTS (TypeError: 'Documentation' object is not iterable)

0 votes

Hi

I am consistently getting the following error when I run stack.sh on my vagrant VM with Ubuntu 14.04.5 OS. I tried to upgrade setuptools and distribute, but none of them were able to solve this error. Can you plz help me how to resolve this error. Plz let me know if u need further data here...

Thanks
Srikanth

2016-10-29 21:52:27.289 | Configuring Horizon

+./stack.sh:main:1057 configure_horizon

+lib/horizon:configurehorizon:79 setupdevelop /opt/stack/horizon

+inc/python:setupdevelop:271 local projectdir=/opt/stack/horizon

+inc/python:setup_develop:272 local extras=

+inc/python:setupdevelop:273 _setuppackagewithconstraints_edit /opt/stack/horizon -e

+inc/python:setuppackagewithconstraintsedit:303 local projectdir=/opt/stack/horizon

+inc/python:setuppackagewithconstraints_edit:304 local flags=-e

+inc/python:setuppackagewithconstraints_edit:305 local extras=

+inc/python:setuppackagewithconstraints_edit:307 '[' -n /opt/stack/requirements ']'

+inc/python:setuppackagewithconstraints_edit:309 local name

++inc/python:setuppackagewithconstraints_edit:310 awk '/^name.*=/ {print $3}' /opt/stack/horizon/setup.cfg

+inc/python:setuppackagewithconstraints_edit:310 name=horizon

+inc/python:setuppackagewithconstraints_edit:312 /opt/stack/requirements/.venv/bin/edit-constraints /opt/stack/requirements/upper-constraints.txt -- horizon '-e file:///opt/stack/horizon#egg=horizon'

+inc/python:setuppackagewithconstraintsedit:316 setuppackage /opt/stack/horizon -e

+inc/python:setuppackage:332 local projectdir=/opt/stack/horizon

+inc/python:setup_package:333 local flags=-e

+inc/python:setup_package:334 local extras=

+inc/python:setup_package:338 [[ -n -e ]]

+inc/python:setup_package:338 [[ -z '' ]]

+inc/python:setup_package:338 [[ ! -e =~ ^-.* ]]

+inc/python:setup_package:343 [[ ! -z '' ]]

+inc/python:setuppackage:347 pipinstall -e /opt/stack/horizon

+inc/python:pip_install:84 local xtrace result

++inc/python:pip_install:85 set +o

++inc/python:pip_install:85 grep xtrace

+inc/python:pip_install:85 xtrace='set -o xtrace'

+inc/python:pip_install:86 set +o xtrace

+inc/python:pipinstall:155 sudo -H httpproxy= httpsproxy= noproxy= PIPFINDLINKS= SETUPTOOLSSYSPATH_TECHNIQUE=rewrite /usr/local/bin/pip2.7 install -c /opt/stack/requirements/upper-constraints.txt --upgrade -e /opt/stack/horizon

Ignoring dnspython3: markers u"python_version=='3.4'" don't match your environment

Obtaining file:///opt/stack/horizon

Obtaining horizon from file:///opt/stack/horizon#egg=horizon (from -c /opt/stack/requirements/upper-constraints.txt (line 1))

Requirement already up-to-date: Babel===2.2.0 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 3))
...
Requirement already up-to-date: python-openstackclient===2.3.0 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 305))
Requirement already up-to-date: python-swiftclient===3.0.0 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 313))
Requirement already up-to-date: pytz===2015.7 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 316))
Collecting rcssmin===1.0.6 (from -c /opt/stack/requirements/upper-constraints.txt (line 320))
Using cached rcssmin-1.0.6.tar.gz
Complete output from command python setup.py egginfo:
running egg
info
creating pip-egg-info/rcssmin.egg-info
writing pip-egg-info/rcssmin.egg-info/PKG-INFO
writing top-level names to pip-egg-info/rcssmin.egg-info/toplevel.txt
writing dependency
links to pip-egg-info/rcssmin.egg-info/dependencylinks.txt
writing manifest file 'pip-egg-info/rcssmin.egg-info/SOURCES.txt'
warning: manifest
maker: standard file '-c' not found

Traceback (most recent call last):
File "", line 1, in
File "/tmp/pip-build-T8bWPt/rcssmin/setup.py", line 42, in
setup()
File "/tmp/pip-build-T8bWPt/rcssmin/setup.py", line 33, in setup
return run(scriptargs=args, ext=ext, manifestonly=manifest)
File "
setup/py2/setup.py", line 421, in run
return _core.setup(**kwargs)
File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
dist.run_commands()
File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
self.run_command(cmd)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 279, in run
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 306, in find_sources
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 533, in run
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 562, in add_defaults
File "build/bdist.linux-x86_64/egg/setuptools/command/py36compat.py", line 35, in add_defaults
File "build/bdist.linux-x86_64/egg/setuptools/command/py36compat.py", line 111, in _add_defaults_data_files
TypeError: 'Documentation' object is not iterable


Command "python setup.py egginfo" failed with error code 1 in /tmp/pip-build-T8bWPt/rcssmin/
+inc/python:pip
install:1 exittrap
+./stack.sh:exit
trap:474 local r=1
++./stack.sh:exittrap:475 jobs -p
+./stack.sh:exit
trap:475 jobs=
+./stack.sh:exittrap:478 [[ -n '' ]]
+./stack.sh:exit
trap:484 killspinner
+./stack.sh:kill
spinner:370 '[' '!' -z '' ']'
+./stack.sh:exittrap:486 [[ 1 -ne 0 ]]
+./stack.sh:exit
trap:487 echo 'Error on exit'
Error on exit
+./stack.sh:exittrap:488 generate-subunit 1477777391 606 fail
+./stack.sh:exit
trap:489 [[ -z /opt/stack/logs ]]
+./stack.sh:exittrap:492 /home/vagrant/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2016-10-29-215317.txt for details
+./stack.sh:exit
trap:498 exit 1


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
asked Oct 29, 2016 in openstack-dev by Srikanth_Vavilapalli (840 points)   2 4
retagged Jan 26, 2017 by admin

2 Responses

0 votes

Hi

One quick update on this issue:

For some reason I see this issue only with devstack mitaka on vagrant VM spawned using virtualbox provider(Ubuntu/trusty64 box). It used to work before though...

On the same vagrant VM, I installed devstack Liberty which is working without any issues. Also I tried devstack mitaka on vagrant VM spawned using libvirt provider and interestingly that is also working.

Not sure what the issue with vagrant virtualbox VM...

Thanks
Srikanth

From: Srikanth Vavilapalli [mailto:srikanth.vavilapalli@ericsson.com]
Sent: Saturday, October 29, 2016 3:03 PM
To: openstack-dev@lists.openstack.org
Subject: [openstack-dev] [devstack][mitaka] Unable stack.sh on ubuntu 14.04.5LTS (TypeError: 'Documentation' object is not iterable)

Hi

I am consistently getting the following error when I run stack.sh on my vagrant VM with Ubuntu 14.04.5 OS. I tried to upgrade setuptools and distribute, but none of them were able to solve this error. Can you plz help me how to resolve this error. Plz let me know if u need further data here...

Thanks
Srikanth

2016-10-29 21:52:27.289 | Configuring Horizon

+./stack.sh:main:1057 configure_horizon

+lib/horizon:configurehorizon:79 setupdevelop /opt/stack/horizon

+inc/python:setupdevelop:271 local projectdir=/opt/stack/horizon

+inc/python:setup_develop:272 local extras=

+inc/python:setupdevelop:273 _setuppackagewithconstraints_edit /opt/stack/horizon -e

+inc/python:setuppackagewithconstraintsedit:303 local projectdir=/opt/stack/horizon

+inc/python:setuppackagewithconstraints_edit:304 local flags=-e

+inc/python:setuppackagewithconstraints_edit:305 local extras=

+inc/python:setuppackagewithconstraints_edit:307 '[' -n /opt/stack/requirements ']'

+inc/python:setuppackagewithconstraints_edit:309 local name

++inc/python:setuppackagewithconstraints_edit:310 awk '/^name.*=/ {print $3}' /opt/stack/horizon/setup.cfg

+inc/python:setuppackagewithconstraints_edit:310 name=horizon

+inc/python:setuppackagewithconstraints_edit:312 /opt/stack/requirements/.venv/bin/edit-constraints /opt/stack/requirements/upper-constraints.txt -- horizon '-e file:///opt/stack/horizon#egg=horizon'

+inc/python:setuppackagewithconstraintsedit:316 setuppackage /opt/stack/horizon -e

+inc/python:setuppackage:332 local projectdir=/opt/stack/horizon

+inc/python:setup_package:333 local flags=-e

+inc/python:setup_package:334 local extras=

+inc/python:setup_package:338 [[ -n -e ]]

+inc/python:setup_package:338 [[ -z '' ]]

+inc/python:setup_package:338 [[ ! -e =~ ^-.* ]]

+inc/python:setup_package:343 [[ ! -z '' ]]

+inc/python:setuppackage:347 pipinstall -e /opt/stack/horizon

+inc/python:pip_install:84 local xtrace result

++inc/python:pip_install:85 set +o

++inc/python:pip_install:85 grep xtrace

+inc/python:pip_install:85 xtrace='set -o xtrace'

+inc/python:pip_install:86 set +o xtrace

+inc/python:pipinstall:155 sudo -H httpproxy= httpsproxy= noproxy= PIPFINDLINKS= SETUPTOOLSSYSPATH_TECHNIQUE=rewrite /usr/local/bin/pip2.7 install -c /opt/stack/requirements/upper-constraints.txt --upgrade -e /opt/stack/horizon

Ignoring dnspython3: markers u"python_version=='3.4'" don't match your environment

Obtaining file:///opt/stack/horizon

Obtaining horizon from file:///opt/stack/horizon#egg=horizon (from -c /opt/stack/requirements/upper-constraints.txt (line 1))

Requirement already up-to-date: Babel===2.2.0 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 3))
...
Requirement already up-to-date: python-openstackclient===2.3.0 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 305))
Requirement already up-to-date: python-swiftclient===3.0.0 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 313))
Requirement already up-to-date: pytz===2015.7 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 316))
Collecting rcssmin===1.0.6 (from -c /opt/stack/requirements/upper-constraints.txt (line 320))
Using cached rcssmin-1.0.6.tar.gz
Complete output from command python setup.py egginfo:
running egg
info
creating pip-egg-info/rcssmin.egg-info
writing pip-egg-info/rcssmin.egg-info/PKG-INFO
writing top-level names to pip-egg-info/rcssmin.egg-info/toplevel.txt
writing dependency
links to pip-egg-info/rcssmin.egg-info/dependencylinks.txt
writing manifest file 'pip-egg-info/rcssmin.egg-info/SOURCES.txt'
warning: manifest
maker: standard file '-c' not found

Traceback (most recent call last):
File "", line 1, in
File "/tmp/pip-build-T8bWPt/rcssmin/setup.py", line 42, in
setup()
File "/tmp/pip-build-T8bWPt/rcssmin/setup.py", line 33, in setup
return run(scriptargs=args, ext=ext, manifestonly=manifest)
File "
setup/py2/setup.py", line 421, in run
return _core.setup(**kwargs)
File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
dist.run_commands()
File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
self.run_command(cmd)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 279, in run
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 306, in find_sources
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 533, in run
File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py", line 562, in add_defaults
File "build/bdist.linux-x86_64/egg/setuptools/command/py36compat.py", line 35, in add_defaults
File "build/bdist.linux-x86_64/egg/setuptools/command/py36compat.py", line 111, in _add_defaults_data_files
TypeError: 'Documentation' object is not iterable


Command "python setup.py egginfo" failed with error code 1 in /tmp/pip-build-T8bWPt/rcssmin/
+inc/python:pip
install:1 exittrap
+./stack.sh:exit
trap:474 local r=1
++./stack.sh:exittrap:475 jobs -p
+./stack.sh:exit
trap:475 jobs=
+./stack.sh:exittrap:478 [[ -n '' ]]
+./stack.sh:exit
trap:484 killspinner
+./stack.sh:kill
spinner:370 '[' '!' -z '' ']'
+./stack.sh:exittrap:486 [[ 1 -ne 0 ]]
+./stack.sh:exit
trap:487 echo 'Error on exit'
Error on exit
+./stack.sh:exittrap:488 generate-subunit 1477777391 606 fail
+./stack.sh:exit
trap:489 [[ -z /opt/stack/logs ]]
+./stack.sh:exittrap:492 /home/vagrant/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2016-10-29-215317.txt for details
+./stack.sh:exit
trap:498 exit 1


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
responded Nov 1, 2016 by Srikanth_Vavilapalli (840 points)   2 4
0 votes

Hi,

Your logs says that it failed during installation of "rcssmin" package.

Did you tried installing it manually, or removing it completely and
re-installing?

It may be because of version conflict across the dependencies for this
package.

Regards,
Ganpat

On Tue, Nov 1, 2016 at 8:10 PM, Srikanth Vavilapalli <
srikanth.vavilapalli@ericsson.com> wrote:

Hi

One quick update on this issue:

For some reason I see this issue only with devstack mitaka on vagrant VM
spawned using virtualbox provider(Ubuntu/trusty64 box). It used to work
before though…

On the same vagrant VM, I installed devstack Liberty which is working
without any issues. Also I tried devstack mitaka on vagrant VM spawned
using libvirt provider and interestingly that is also working.

Not sure what the issue with vagrant virtualbox VM…

Thanks

Srikanth

From: Srikanth Vavilapalli [mailto:srikanth.vavilapalli@ericsson.com]
Sent: Saturday, October 29, 2016 3:03 PM
To: openstack-dev@lists.openstack.org
Subject: [openstack-dev] [devstack][mitaka] Unable stack.sh on ubuntu
14.04.5LTS (TypeError: 'Documentation' object is not iterable)

Hi

I am consistently getting the following error when I run stack.sh on my
vagrant VM with Ubuntu 14.04.5 OS. I tried to upgrade setuptools and
distribute, but none of them were able to solve this error. Can you plz
help me how to resolve this error. Plz let me know if u need further data
here…

Thanks

Srikanth

2016-10-29 21:52:27.289 | Configuring Horizon

+./stack.sh:main:1057 configure_horizon

+lib/horizon:configurehorizon:79 setupdevelop
/opt/stack/horizon

+inc/python:setupdevelop:271 local
project
dir=/opt/stack/horizon

+inc/python:setup_develop:272 local extras=

+inc/python:setupdevelop:273 _setuppackagewithconstraints_edit
/opt/stack/horizon -e

+inc/python:setuppackagewithconstraintsedit:303 local
project
dir=/opt/stack/horizon

+inc/python:setuppackagewithconstraints_edit:304 local flags=-e

+inc/python:setuppackagewithconstraints_edit:305 local extras=

+inc/python:setuppackagewithconstraints_edit:307 '[' -n
/opt/stack/requirements ']'

+inc/python:setuppackagewithconstraints_edit:309 local name

++inc/python:setuppackagewithconstraints_edit:310 awk '/^name.*=/
{print $3}' /opt/stack/horizon/setup.cfg

+inc/python:setuppackagewithconstraints_edit:310 name=horizon

+inc/python:setuppackagewithconstraints_edit:312
/opt/stack/requirements/.venv/bin/edit-constraints
/opt/stack/requirements/upper-constraints.txt -- horizon '-e
file:///opt/stack/horizon#egg=horizon'

+inc/python:setuppackagewithconstraintsedit:316 setuppackage
/opt/stack/horizon -e

+inc/python:setuppackage:332 local
project
dir=/opt/stack/horizon

+inc/python:setup_package:333 local flags=-e

+inc/python:setup_package:334 local extras=

+inc/python:setup_package:338 [[ -n -e ]]

+inc/python:setup_package:338 [[ -z '' ]]

+inc/python:setup_package:338 [[ ! -e =~ ^-.* ]]

+inc/python:setup_package:343 [[ ! -z '' ]]

+inc/python:setuppackage:347 pipinstall -e
/opt/stack/horizon

+inc/python:pip_install:84 local xtrace result

++inc/python:pip_install:85 set +o

++inc/python:pip_install:85 grep xtrace

+inc/python:pip_install:85 xtrace='set -o xtrace'

+inc/python:pip_install:86 set +o xtrace

+inc/python:pipinstall:155 sudo -H httpproxy=
httpsproxy= noproxy= PIPFINDLINKS= SETUPTOOLSSYSPATH_TECHNIQUE=rewrite
/usr/local/bin/pip2.7 install -c /opt/stack/requirements/upper-constraints.txt
--upgrade -e /opt/stack/horizon

Ignoring dnspython3: markers u"python_version=='3.4'" don't match your
environment

Obtaining file:///opt/stack/horizon

Obtaining horizon from file:///opt/stack/horizon#egg=horizon (from -c
/opt/stack/requirements/upper-constraints.txt (line 1))

Requirement already up-to-date: Babel===2.2.0 in
/usr/local/lib/python2.7/dist-packages (from -c
/opt/stack/requirements/upper-constraints.txt (line 3))

Requirement already up-to-date: python-openstackclient===2.3.0 in
/usr/local/lib/python2.7/dist-packages (from -c
/opt/stack/requirements/upper-constraints.txt (line 305))

Requirement already up-to-date: python-swiftclient===3.0.0 in
/usr/local/lib/python2.7/dist-packages (from -c
/opt/stack/requirements/upper-constraints.txt (line 313))

Requirement already up-to-date: pytz===2015.7 in
/usr/local/lib/python2.7/dist-packages (from -c
/opt/stack/requirements/upper-constraints.txt (line 316))

Collecting rcssmin===1.0.6 (from -c /opt/stack/requirements/upper-constraints.txt
(line 320))

Using cached rcssmin-1.0.6.tar.gz

Complete output from command python setup.py egg_info:

running egg_info

creating pip-egg-info/rcssmin.egg-info

writing pip-egg-info/rcssmin.egg-info/PKG-INFO

writing top-level names to pip-egg-info/rcssmin.egg-info/top_level.txt

writing dependencylinks to pip-egg-info/rcssmin.egg-info/
dependency
links.txt

writing manifest file 'pip-egg-info/rcssmin.egg-info/SOURCES.txt'

warning: manifest_maker: standard file '-c' not found

Traceback (most recent call last):

 File "<string>", line 1, in <module>

 File "/tmp/pip-build-T8bWPt/rcssmin/setup.py", line 42, in <module>

   setup()

 File "/tmp/pip-build-T8bWPt/rcssmin/setup.py", line 33, in setup

   return run(script_args=args, ext=ext, manifest_only=_manifest)

 File "_setup/py2/setup.py", line 421, in run

   return _core.setup(**kwargs)

 File "/usr/lib/python2.7/distutils/core.py", line 151, in setup

   dist.run_commands()

 File "/usr/lib/python2.7/distutils/dist.py", line 953, in

run_commands

   self.run_command(cmd)

 File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command

   cmd_obj.run()

 File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py",

line 279, in run

 File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py",

line 306, in find_sources

 File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py",

line 533, in run

 File "build/bdist.linux-x86_64/egg/setuptools/command/egg_info.py",

line 562, in add_defaults

 File "build/bdist.linux-x86_64/egg/setuptools/command/py36compat.py",

line 35, in add_defaults

 File "build/bdist.linux-x86_64/egg/setuptools/command/py36compat.py",

line 111, in adddefaultsdatafiles

TypeError: 'Documentation' object is not iterable


Command "python setup.py egg_info" failed with error code 1 in
/tmp/pip-build-T8bWPt/rcssmin/

+inc/python:pipinstall:1 exittrap

+./stack.sh:exit_trap:474 local r=1

++./stack.sh:exit_trap:475 jobs -p

+./stack.sh:exit_trap:475 jobs=

+./stack.sh:exit_trap:478 [[ -n '' ]]

+./stack.sh:exittrap:484 killspinner

+./stack.sh:kill_spinner:370 '[' '!' -z '' ']'

+./stack.sh:exit_trap:486 [[ 1 -ne 0 ]]

+./stack.sh:exit_trap:487 echo 'Error on exit'

Error on exit

+./stack.sh:exit_trap:488 generate-subunit 1477777391
606 fail

+./stack.sh:exit_trap:489 [[ -z /opt/stack/logs ]]

+./stack.sh:exit_trap:492 /home/vagrant/devstack/tools/worlddump.py
-d /opt/stack/logs

World dumping... see /opt/stack/logs/worlddump-2016-10-29-215317.txt for
details

+./stack.sh:exit_trap:498 exit 1


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
responded Nov 2, 2016 by Ganpat_Agarwal (480 points)   1 1
...