settingsLogin | Registersettings

Search:

Recent questions tagged haproxy

0 votes
11 responses 55 views

Hi, all, I created a lb whose vip is 10.0.1.4. When requesting the vip, i cannot receive the responses. Hence, I console in the amphora and trace packets handled by eth0 in the amphora-haproxy network namespace. The detailed info is as ...

asked Nov 14, 2017 in openstack-dev by Yipei_Niu (2,060 points)   2 8
0 votes
8 responses 12 views

Dears, I need to generate the .pem file based on certifcate files (.cert). The key (.key file) is available too. All my files can be read as text files. Could you please detail the procedure for this ? I am using ubuntu as OS. Thanks in ...

asked Nov 9, 2017 in openstack by David_Gabriel (600 points)   1 1
0 votes
0 responses 58 views

Hello, I am working on deploying a lab environment using openstack-ansible. While executing the setup-openstack.yml I encounter errors on the following task: TASK [os_glance : Ensure glance service] ...

asked Oct 26, 2017 in openstack-operators by andres_sanchez_ramos (300 points)   2
0 votes
13 responses 41 views

When I setup my OS cluster over a year ago, I chose to use distributed LBaaSv2. That sounded like the most sensible thing - redundancy is the primary goal with me choosing OS in the first place! However, it turned out that there’s a very ...

asked Oct 21, 2017 in openstack by Turbo_Fredriksson (8,980 points)   7 12 14
9 x  
0 votes
0 responses 382 views

Hi colleagues, I have an issue with launching 'amphora' image. I'm using Octavia's diskimage-create.sh tool on Ubuntu 16.04.3, which gives the following start: > Building elements: base  base vm ubuntu haproxy-octavia-ubuntu rebind-sshd ...

asked Oct 20, 2017 in openstack by Volodymyr_Litovka (1,100 points)   1 6 8
0 votes
0 responses 40 views

Dear all, Hope this is the right ML for this question, otherwise please let me know. I have setup an openstack-ansible based infrastructure (pike) with 3 controllers and 8 computes. Everything works fine except when i configure a dedicated ...

asked Oct 18, 2017 in openstack-operators by Matteo_Gerola (120 points)  
0 votes
7 responses 21 views

Hello, Does the agent implementation of LBaaSv2 support L7 policies? I am testing with Mitaka version and I get "Not Implemented Error". {"asctime": "2017-10-03 07:34:42.764","process": "18","levelname": "INFO","name": ...

asked Oct 13, 2017 in openstack-dev by mihaela.balas_at_ora (480 points)   1 1
0 votes
10 responses 54 views

Hi, all, I encounter some problems when using Octavia. After installing octavia with devstack, I create a load balancer named lb1 (VIP: 10.0.1.9, IP of VRRP port: 10.0.1.3) for a subnet (10.0.1.0/24), then a listener, a pool, and two ...

asked Oct 9, 2017 in openstack-dev by Yipei_Niu (2,060 points)   2 8
0 votes
11 responses 39 views

Hello all, We have a number of old stable/* branches hanging around and I'd like to mark anything <= stable/mitaka as EOL. I've highlighted a few projects on the subject line: QA: Are the older branches of grenade safe to go? IIUC we don't ...

asked Sep 24, 2017 in openstack-dev by Tony_Breeds (19,660 points)   3 6 10
6 x  
0 votes
3 responses 675 views

I had HA setup for placement api to work on high availability enviornment by using HAproxy on three controller nodes vim /etc/haproxy/haproxy.cfg listen nova_placement_cluster bind 0.0.0.0:8778 http-request del-header X-Forwarded-Proto ...

asked Sep 22, 2017 in openstack by 谭_明宵 (200 points)   1 1 1
0 votes
1 response 37 views

Hi Liping, FYI, Neutron LBaaS is no longer part of Neutron. Load balancing has been consolidated under the Octavia project. I have added that tag to the subject. We currently do not have plans to add HA capabilities to the haproxy namespace ...

asked Sep 10, 2017 in openstack-dev by Michael_Johnson (4,380 points)   4 5
0 votes
0 responses 44 views

Hi Neutron LBaaS team, One quick question about HA LBaaS V2 with haproxy namespace driver(not Octavia). Do we have any plan to support Haproxy HA with Keepalived? (Something similar with L3 HA). I see we got some patch supported some level ...

asked Sep 10, 2017 in openstack-dev by Liping_Mao_-X_(limao (1,580 points)   5
0 votes
0 responses 108 views

Hi all, I am setting up a high available OpenStack control plan. I have three controllers each running HAproxy, pacemaker, keystone, Mariadb Galera, cinder (api +volume), memcahed, rabbitmq and neutron with OVS DVR and VRRP. Since I am ...

asked Sep 9, 2017 in openstack by Imran_Ahmed (120 points)   1 1
0 votes
5 responses 48 views

Hey, all. We want to proof something out with SSL-enabled endpoints, and don't want to go through the grief of setting up a whole multi-host cloud to do it. Devstack with USE_SSL=True in its local.conf seemed to be just the ticket... except ...

asked Aug 29, 2017 in openstack by Ken_D'Ambrosio (1,180 points)   1 7 11
0 votes
4 responses 20 views

On Thu, Aug 24, 2017 at 11:15 AM, Jeffrey Zhang wrote: > We are moving to deploy service via WSGI[0]. > > There are two recommended ways. > > - apache + mod_wsgi > - nginx + uwsgi > > later one is more better. > > For traditional ...

asked Aug 25, 2017 in openstack-dev by Mohammed_Naser (3,860 points)   1 3
0 votes
5 responses 850 views

Hi, I am installing Redhat openstack platform 10 on virtual environment (KVM) using pxe_ssh ipmi driver. Undercloud, compute, controller all three nodes are available on single kvm box. Using single nic config. Overcloud deployment failing ...

asked Aug 24, 2017 in openstack by Shyam_Biradar (420 points)   2 3 3
 
0 votes
1 response 7 views

Hi All, Just have a quick question that I am sure someone has already come across before: We have been trying to get SSL endpoints working using our own SSL certificates. We get failures during the installation process, but when we disable ...

asked Aug 3, 2017 in openstack-operators by Grant (1,040 points)   1 3
0 votes
4 responses 9 views

Our current model for logging in a containerized deployment has pretty much everything logging to files in a directory that has been bind-mounted from the host. This has some advantages: primarily, it makes it easy for an operator on the ...

asked Jul 19, 2017 in openstack-dev by Lars_Kellogg-Stedman (1,960 points)   2 4
0 votes
0 responses 478 views

Hello all, I'm currently having a issue whereby I'm unable to login with horizon even after logs show that authentication was successful. I am able to use the command line successfully without issue. In my troubleshooting I've tried to ...

asked Jul 12, 2017 in openstack by Casey_Richins (120 points)   1 1
0 votes
0 responses 6 views

My goal is install the OpenDaylight SFC features in OPNFV with the use of no-ha_odl-l2_sfc_heat_ceilometer_scenario.yaml . To perform a virtual deployment of an OPNFV SFC scenario on a single host, my host (is a virtual machine over ...

asked Jul 6, 2017 in openstack-dev by rosa.fernandez_at_es (120 points)  
...