settingsLogin | Registersettings

Search:

Recent questions tagged wsgi

0 votes
15 responses 12 views

Hi everyone, I'm looking for some help regarding an issue that we're having with the Puppet OpenStack modules, we've had very inconsistent failures in the Xenial with the following error: ...

asked Nov 14, 2017 in openstack-dev by Mohammed_Naser (3,860 points)   1 3
0 votes
15 responses 15 views

Dear Stackers, While working on my locally deployed Openstack (Pike using TripleO), I was a bit struggling with the logging part. Currently, all logs are pushed to per-service files, in the standard format "one line per entry", plain flat ...

asked Nov 6, 2017 in openstack-dev by Cédric_Jeanneret (240 points)  
4 x  
0 votes
1 response 8 views

Hi team, We all know that unfortunately Horizon's performance not good enough in some cases. That's why we try to fix it on both sides: client-side and server-side. I would like to talk mostly about server-side now. On some views, we use ...

asked Oct 31, 2017 in openstack-dev by Ivan_Kolodyazhny (3,680 points)   4 6
0 votes
2 responses 13 views

Hi, We are glad to present this week's priorities and subteam report for Ironic. As usual, this is pulled directly from the Ironic whiteboard[0] and formatted. This Week's Priorities (as of the weekly ironic meeting) ...

asked Oct 30, 2017 in openstack-dev by Yeleswarapu,_Ramaman (1,240 points)   1
0 votes
1 response 354 views

Hi, Is it possible to have both v2.0 and v3 endpoints for Keystone? I’m trying to integrate a backup software into Swift, and it requires Keystone 2.0. I added the new endpoints fine, but I’m getting authentication/authorization errors: ...

asked Oct 26, 2017 in openstack-operators by Andy_Wojnarek (440 points)   3 3
 
0 votes
8 responses 279 views

Hello All, We are trying to deploy one environment using Fuel 9.2, and it failed at around 23%. The error says: <> Error Provision has failed. Failed to execute hook 'shell' command: cd / && fa_build_image --image_build_dir ...

asked Oct 25, 2017 in openstack by Raja_T_Nair (1,020 points)   2 3
0 votes
11 responses 5 views

Should this kind of change be discussed and have an agreement of the TC and User committee? ---------- Forwarded message ---------- From: Lance Bragstad Date: Fri, Oct 20, 2017 at 12:08 AM Subject: [Openstack-operators] [keystone][all] v2.0 ...

asked Oct 23, 2017 in openstack-dev by Yaguang_Tang (1,180 points)   1 2 4
4 x  
0 votes
0 responses 250 views

Hello everyone, In my pike lab setup I am having an issue with using an https endpoint for the compute service only through horizon. The python client works fine. Below is what I am seeing. If you think its a bug let me know and I will file ...

asked Oct 19, 2017 in openstack by Steve_Searles (480 points)   3 3
0 votes
2 responses 15 views

Hi, We have our API server(based on pyramid) integrated with keystone for AuthN/AuthZ. So our service has a *.conf file which has [keystone_authtoken] section that defines all the stuff needed for registering to keystone. WSGI pipeline will ...

asked Oct 11, 2017 in openstack-dev by pn_kk (640 points)   1 1 1
 
0 votes
4 responses 266 views

Hi, i've upgraded from newton to ocata and i my last problem (i hope so) is in the nova-api. if i try to create a new instance (horizon or cli) i get an "404 instance no found" error but is instance is created and started as well. ...

asked Oct 11, 2017 in openstack-dev by Kim-Norman_Sahm (320 points)   4 4
2 x  
0 votes
5 responses 34 views

Hi all; About 18 months ago I did a piece by piece install of Liberty (following instructions on the Openstack page) and had been using it until somewhat recently when it broke after a CentOS 7 update ran. I think Python/http is what ...

asked Oct 10, 2017 in openstack-operators by Christopher_Hull (2,220 points)   1 4 7
0 votes
2 responses 13 views

Hi, We are glad to present this week's priorities and subteam report for Ironic. As usual, this is pulled directly from the Ironic whiteboard[0] and formatted. This Week's Priorities (as of the weekly ironic meeting) ...

asked Oct 9, 2017 in openstack-dev by Yeleswarapu,_Ramaman (1,240 points)   1
0 votes
0 responses 21 views

Hi all! Here are my notes from the ironic (and a bit of nova) room in Denver. The same content in a nicely rendered form is on my blog: http://dtantsur.github.io/posts/ironic-ptg-denver-2017-1.html ...

asked Oct 6, 2017 in openstack-dev by Dmitry_Tantsur (18,080 points)   2 3 5
0 votes
1 response 8 views

Hi, I come across a questionable behavior of nova while I tried to use the notify_on_api_faults configuration option [0] while testing the related versioned notification transformation patch [1]. Based on the description of the config ...

asked Sep 26, 2017 in openstack-dev by =?iso-8859-1?Q?Bal=E (5,020 points)   1 2 3
0 votes
2 responses 14 views

Hi, We are glad to present this week's priorities and subteam report for Ironic. As usual, this is pulled directly from the Ironic whiteboard[0] and formatted. This Week's Priorities (as of the weekly ironic meeting) ...

asked Sep 18, 2017 in openstack-dev by Yeleswarapu,_Ramaman (1,240 points)   1
0 votes
11 responses 16 views

Hi folks, I've attempted to enable mod_wsgi support in our dev environment with Puppet however it results in a traceback. I figured it was an environment thing so I looked into moving the Puppet CI to test using mod_wsgi and it resulted in ...

asked Sep 15, 2017 in openstack-dev by Mohammed_Naser (3,860 points)   1 3
 
0 votes
7 responses 15 views

On Mon, Sep 4, 2017 at 9:01 AM, Kevin Benton wrote: > Yes, unfortunately I didn't make it back to the patch in time to adjust > devstack to dump all of the configuration into one file (instead of > /etc/neutron/neutron.conf ...

asked Sep 4, 2017 in openstack-dev by Mohammed_Naser (3,860 points)   1 3
0 votes
1 response 29 views

We are moving to deploy service via WSGI[0]. There are two recommended ways. - apache + mod_wsgi - nginx + uwsgi later one is more better. For traditional deployment, it is easy to implement. Use one uwsgi progress to launch all wsgi ...

asked Aug 25, 2017 in openstack-dev by Lei_Zhang (6,360 points)   1 2 5
0 votes
4 responses 17 views

On Thu, Aug 24, 2017 at 11:15 AM, Jeffrey Zhang wrote: > We are moving to deploy service via WSGI[0]. > > There are two recommended ways. > > - apache + mod_wsgi > - nginx + uwsgi > > later one is more better. > > For traditional ...

asked Aug 25, 2017 in openstack-dev by Mohammed_Naser (3,860 points)   1 3
0 votes
0 responses 6 views

Hello Glancers, Two new bugs. 1) https://launchpad.net/bugs/1712462 is release-critical; I have a patch up for it: https://review.openstack.org/#/c/496477/ . Erno and anyone else knowledgeable about taskflow please look it over. 2) ...

asked Aug 23, 2017 in openstack-dev by rosmaita.fossdev_at_ (4,180 points)   1 2 2
...